summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-25 09:10:08 +0100
committerRemi Collet <remi@php.net>2022-02-25 09:10:08 +0100
commit810a61bdf8c2eb3a879b983956dbbdede8417e7a (patch)
tree7a3555edcd0e403f78d5bf3ca07727ab8585c203 /php-pecl-http.spec
parent47ba3ded308d8edf7a48be5ee5e2c1c1b2f636c8 (diff)
add upstream patch for recent libcurl
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 75a9d51..7523bcb 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -36,7 +36,7 @@
%bcond_without tests
%endif
-%global upstream_version 4.2.2
+%global upstream_version 4.2.1
#global upstream_prever beta1
#global upstream_lower beta1
@@ -46,7 +46,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -57,6 +57,9 @@ URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+# Upstream patches for recent libcurl
+Patch0: %{proj_name}-upstream.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -152,6 +155,8 @@ mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .up
+
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -335,10 +340,10 @@ fi
%changelog
-* Mon Feb 21 2022 Remi Collet <remi@remirepo.net> - 4.2.2-0
-- test build for upcoming 4.2.2
+* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 4.2.1-0
+- add upstream patch for recent libcurl
-* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 1.11.0~alpha1-2
+* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 4.2.1-2
- rebuild using ICU 69
* Mon Sep 13 2021 Remi Collet <remi@remirepo.net> - 4.2.1-1