summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-04 15:37:15 +0100
committerRemi Collet <remi@remirepo.net>2019-02-04 15:37:15 +0100
commit5436f0cc69b3bf7e056f0197e6aef43b188a0101 (patch)
treec98102cf48b7e580654ca49bf83e442bcf1b7852 /php-pecl-http.spec
parente845d610b6e2be25506a6ca8672dd47bddba41ce (diff)
- test build for https://github.com/m6w6/ext-http/pull/85
- ignore failed test with recent libcurl reported as https://github.com/m6w6/ext-http/issues/84
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec22
1 files changed, 20 insertions, 2 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index d579b72..d98818c 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2018 Remi Collet
+# Copyright (c) 2012-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -50,7 +50,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -61,6 +61,8 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+Patch0: https://patch-diff.githubusercontent.com/raw/m6w6/ext-http/pull/85.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
@@ -176,6 +178,8 @@ mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .pr85
+
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -194,6 +198,7 @@ cp -pr NTS ZTS
%build
%{?dtsenable}
+gcc --version
peclconf() {
%configure \
@@ -283,7 +288,15 @@ done
--modules | grep %{pecl_name}
%if %{with_tests}
+: ignore tests with erratic results
rm ?TS/tests/client022.phpt
+rm ?TS/tests/client027.phpt
+%if 0%{?fedora} >= 30
+: https://github.com/m6w6/ext-http/issues/84
+rm ?TS/tests/client008.phpt
+rm ?TS/tests/client018.phpt
+rm ?TS/tests/client021.phpt
+%endif
: Upstream test suite NTS extension
cd NTS
@@ -354,6 +367,11 @@ fi
%changelog
+* Mon Feb 4 2019 Remi Collet <remi@remirepo.net> - 3.2.0-3
+- test build for https://github.com/m6w6/ext-http/pull/85
+- ignore failed test with recent libcurl
+ reported as https://github.com/m6w6/ext-http/issues/84
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 3.2.0-2
- rebuild for 7.3.0beta2 new ABI