summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-03 11:56:45 +0200
committerRemi Collet <remi@remirepo.net>2017-07-03 11:56:45 +0200
commit3fe4b0356fb35d9b603305073ce86e8e0ad06a54 (patch)
tree021da131ef7fecfc66b3a3188d664620af037d38 /php-pecl-http.spec
parent62819c03c515797898c1ab6d36021d5e5ed7dba8 (diff)
v3.1.1RC1
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 3fcacab..28ae37e 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -22,7 +22,6 @@
%global gh_owner m6w6
%global gh_project ext-http
#global gh_date 20150928
-#global prever RC1
# The project is pecl_http but the extension is only http
%global proj_name pecl_http
%global pecl_name http
@@ -36,15 +35,17 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-#global prever RC1
+%global upstream_version 3.1.1
+%global upstream_prever RC1
+
Name: %{?sub_prefix}php-pecl-http
-Version: 3.1.0
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date:1}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{proj_name}-%{version}%{?prever}.tgz
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -55,8 +56,6 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-Patch0: 1b1435c135c69d81b47f1f0662633867c5c289b5.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
@@ -159,17 +158,16 @@ These are the files needed to compile programs using HTTP extension.
mv %{gh_project}-%{gh_commit} NTS
mv NTS/package.xml .
%else
-mv %{proj_name}-%{version}%{?prever} NTS
+mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%endif
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .upstream
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
-if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:dev}"; then
- : Error: Upstream HTTP version is now ${extver}, expecting %{version}%{?prever}%{?gh_date:dev}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
+ : Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
: Update the pdover macro and rebuild.
exit 1
fi
@@ -341,6 +339,9 @@ fi
%changelog
+* Mon Jul 3 2017 Remi Collet <remi@remirepo.net> - 3.1.1~RC1-1
+- update to 3.1.1RC1
+
* Fri Jun 23 2017 Remi Collet <remi@remirepo.net> - 3.1.0-5
- add upstream patch for 7.2