summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-10 10:22:41 +0200
committerRemi Collet <remi@remirepo.net>2018-04-10 10:22:41 +0200
commit3a580096baeb46c5bd3bf3369c41fac92c2973b8 (patch)
tree67952cae5089e89cf6cf3603d8f830bc63c68386 /php-pecl-http.spec
parent9179bf995a1cd295387893d49194572f18ef517e (diff)
update to 3.2.0RC1
enable brotli compression support on F28+
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec29
1 files changed, 24 insertions, 5 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 12a7cca..6142e67 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -16,6 +16,12 @@
%global _root_prefix %{_prefix}
%endif
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+%global with_libbrotli 1
+%else
+%global with_libbrotli 0
+%endif
+
%global gh_commit a84b499418ee7b8992fd9e7e2abc661735a869bd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -35,7 +41,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.1.1
+%global upstream_version 3.2.0
%global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -44,18 +50,18 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
@@ -70,6 +76,9 @@ BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
BuildRequires: openssl-devel
+%if %{?with_libbrotli}
+BuildRequires: brotli-devel >= 1.0
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -139,7 +148,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package devel
Summary: Extended HTTP support developer files (header)
-Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa} >= 5.3.0
Obsoletes: %{?scl_prefix}php-pecl-http1-devel < 2
@@ -182,6 +190,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
peclconf() {
%configure \
--with-http \
@@ -195,6 +205,9 @@ peclconf() {
--without-http-libidnkit2-dir \
--with-http-libicu-dir=%{_root_prefix} \
--with-http-libevent-dir=%{_root_prefix} \
+%if %{?with_libbrotli}
+ --with-http-libbrotli-dir=%{_root_prefix} \
+%endif
--with-libdir=%{_lib} \
--with-php-config=$1
grep IDNA config.h
@@ -213,6 +226,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -301,7 +316,7 @@ NO_INTERACTION=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -344,6 +359,10 @@ fi
%changelog
+* Tue Apr 10 2018 Remi Collet <remi@remirepo.net> - 3.2.0~RC1-1
+- update to 3.2.0RC1
+- enable brotli compression support on F28+
+
* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 3.1.1~RC1-3
- ignore 1 failed test with libcurl 7.55
https://github.com/m6w6/ext-http/issues/72