summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-19 11:00:13 +0200
committerRemi Collet <remi@remirepo.net>2021-04-19 11:00:13 +0200
commitb016ecc1964b39060df7ced8d7dd0ab7803b77de (patch)
tree3cee35671211f1f94ec60ec06855eae11e848541
parent5ee73cb1e8daa8bb1481ffbd58fb09e4b32f1da1 (diff)
update to 4.1.0
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION43
-rw-r--r--php-pecl-http.spec5
4 files changed, 42 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index bd04b69..bbf55e0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
http
HTTP Support => enabled
-Extension Version => 4.0.0
+Extension Version => 4.1.0
Used Library => Compiled => Linked
libz => 1.2.11 => 1.2.11
diff --git a/REFLECTION b/REFLECTION
index fefeaaa..08a7638 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 http version 4.0.0 ] {
+Extension [ <persistent> extension #82 http version 4.1.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -11,11 +11,10 @@ Extension [ <persistent> extension #80 http version 4.0.0 ] {
}
}
- - Constants [56] {
+ - Constants [83] {
Constant [ int http\Client\Curl\FEATURES ] { 12568477 }
Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
- Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
Constant [ int http\Client\Curl\Features\SSL ] { 4 }
Constant [ int http\Client\Curl\Features\LIBZ ] { 8 }
Constant [ int http\Client\Curl\Features\NTLM ] { 16 }
@@ -25,42 +24,66 @@ Extension [ <persistent> extension #80 http version 4.0.0 ] {
Constant [ int http\Client\Curl\Features\LARGEFILE ] { 512 }
Constant [ int http\Client\Curl\Features\IDN ] { 1024 }
Constant [ int http\Client\Curl\Features\SSPI ] { 2048 }
- Constant [ int http\Client\Curl\Features\GSSAPI ] { 131072 }
Constant [ int http\Client\Curl\Features\TLSAUTH_SRP ] { 16384 }
Constant [ int http\Client\Curl\Features\NTLM_WB ] { 32768 }
Constant [ int http\Client\Curl\Features\HTTP2 ] { 65536 }
+ Constant [ int http\Client\Curl\Features\GSSAPI ] { 131072 }
+ Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
Constant [ int http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ int http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.71.1 OpenSSL/1.1.1i-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.41.0 }
+ Constant [ int http\Client\Curl\Features\HTTPS_PROXY ] { 2097152 }
+ Constant [ int http\Client\Curl\Features\MULTI_SSL ] { 4194304 }
+ Constant [ int http\Client\Curl\Features\BROTLI ] { 8388608 }
+ Constant [ int http\Client\Curl\Features\ALTSVC ] { 16777216 }
+ Constant [ int http\Client\Curl\Features\HTTP3 ] { 33554432 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.71.1 OpenSSL/1.1.1k-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.43.0 }
Constant [ string http\Client\Curl\Versions\CURL ] { 7.71.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1i-fips }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1k-fips }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
+ Constant [ null http\Client\Curl\Versions\ARES ] { }
+ Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.0 }
+ Constant [ null http\Client\Curl\Versions\ICONV ] { }
+ Constant [ string http\Client\Curl\Versions\BROTLI ] { 1.0.9 }
+ Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.43.0 }
+ Constant [ null http\Client\Curl\Versions\QUIC ] { }
+ Constant [ string http\Client\Curl\Versions\CAINFO ] { /etc/pki/tls/certs/ca-bundle.crt }
+ Constant [ null http\Client\Curl\Versions\CAPATH ] { }
Constant [ int http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
Constant [ int http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
Constant [ int http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_2_PRIOR_KNOWLEDGE ] { 5 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_3 ] { 30 }
Constant [ int http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_1 ] { 5 }
Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_2 ] { 6 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_3 ] { 7 }
Constant [ int http\Client\Curl\SSL_VERSION_SSLv2 ] { 2 }
Constant [ int http\Client\Curl\SSL_VERSION_SSLv3 ] { 3 }
Constant [ int http\Client\Curl\SSL_VERSION_ANY ] { 0 }
Constant [ int http\Client\Curl\TLSAUTH_SRP ] { 1 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_DEFAULT ] { 65536 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_0 ] { 262144 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_1 ] { 327680 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_2 ] { 393216 }
+ Constant [ int http\Client\Curl\SSL_VERSION_MAX_TLSv1_3 ] { 458752 }
Constant [ int http\Client\Curl\IPRESOLVE_V4 ] { 1 }
Constant [ int http\Client\Curl\IPRESOLVE_V6 ] { 2 }
Constant [ int http\Client\Curl\IPRESOLVE_ANY ] { 0 }
+ Constant [ int http\Client\Curl\AUTH_NONE ] { 0 }
Constant [ int http\Client\Curl\AUTH_BASIC ] { 1 }
Constant [ int http\Client\Curl\AUTH_DIGEST ] { 2 }
Constant [ int http\Client\Curl\AUTH_DIGEST_IE ] { 16 }
Constant [ int http\Client\Curl\AUTH_NTLM ] { 8 }
Constant [ int http\Client\Curl\AUTH_GSSNEG ] { 4 }
Constant [ int http\Client\Curl\AUTH_SPNEGO ] { 4 }
+ Constant [ int http\Client\Curl\AUTH_BEARER ] { 64 }
Constant [ int http\Client\Curl\AUTH_ANY ] { -17 }
Constant [ int http\Client\Curl\PROXY_SOCKS4 ] { 4 }
- Constant [ int http\Client\Curl\PROXY_SOCKS4A ] { 5 }
- Constant [ int http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 5 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS4A ] { 6 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 7 }
Constant [ int http\Client\Curl\PROXY_SOCKS5 ] { 5 }
Constant [ int http\Client\Curl\PROXY_HTTP ] { 0 }
Constant [ int http\Client\Curl\PROXY_HTTP_1_0 ] { 1 }
@@ -68,6 +91,10 @@ Extension [ <persistent> extension #80 http version 4.0.0 ] {
Constant [ int http\Client\Curl\POSTREDIR_302 ] { 2 }
Constant [ int http\Client\Curl\POSTREDIR_303 ] { 4 }
Constant [ int http\Client\Curl\POSTREDIR_ALL ] { 7 }
+ Constant [ int http\Client\Curl\ALTSVC_READONLYFILE ] { 4 }
+ Constant [ int http\Client\Curl\ALTSVC_H1 ] { 8 }
+ Constant [ int http\Client\Curl\ALTSVC_H2 ] { 16 }
+ Constant [ int http\Client\Curl\ALTSVC_H3 ] { 32 }
}
- Classes [33] {
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index f395aa4..3a1d322 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -36,7 +36,7 @@
%bcond_without tests
%endif
-%global upstream_version 4.0.0
+%global upstream_version 4.1.0
#global upstream_prever beta1
#global upstream_lower beta1
@@ -330,6 +330,9 @@ fi
%changelog
+* Mon Apr 19 2021 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+
* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0 (stable)