summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-11 15:56:13 +0200
committerRemi Collet <remi@php.net>2023-05-11 15:56:13 +0200
commit9984ee190381f64f6402225bfcacdf47aa57a35a (patch)
treedea4464fa62089d4c3c15e6a7d62f7e2dcced6e4
parent5dd06ba7efbd21536f1553cb32a2bf0318935c14 (diff)
rebuild using ICU 72
use SPDX license ID
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION105
-rw-r--r--php-pecl-http.spec39
3 files changed, 93 insertions, 57 deletions
diff --git a/PHPINFO b/PHPINFO
index d215c97..7bd5ef2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,10 +5,10 @@ HTTP Support => enabled
Extension Version => 4.2.3
Used Library => Compiled => Linked
-libz => 1.2.11 => 1.2.11
-libcurl => 7.79.1 => 7.79.1
+libz => 1.2.12 => 1.2.12
+libcurl => 7.85.0 => 7.85.0
libevent => 2.1.12-stable => 2.1.12-stable
-libicu (IDNA2008/IDNA2003) => 69.1 => 69.1
+libicu (IDNA2008/IDNA2003) => 72.1 => 72.1
libidn2 (IDNA2008) => disabled => disabled
libidn (IDNA2003) => disabled => disabled
libidnkit2 (IDNA2008) => disabled => disabled
diff --git a/REFLECTION b/REFLECTION
index 7d78cb0..37e8121 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 http version 4.2.3 ] {
+Extension [ <persistent> extension #110 http version 4.2.3 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -12,7 +12,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
}
- Constants [91] {
- Constant [ int http\Client\Curl\FEATURES ] { 297781149 }
+ Constant [ int http\Client\Curl\FEATURES ] { 1371522973 }
Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ int http\Client\Curl\Features\SSL ] { 4 }
@@ -39,15 +39,15 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
Constant [ int http\Client\Curl\Features\ZSTD ] { 67108864 }
Constant [ int http\Client\Curl\Features\UNICODE ] { 134217728 }
Constant [ int http\Client\Curl\Features\HSTS ] { 268435456 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.79.1 OpenSSL/1.1.1n-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.79.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1n-fips }
- Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.85.0 OpenSSL/3.0.8 zlib/1.2.12 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.3) libssh/0.10.4/openssl/zlib nghttp2/1.51.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.85.0 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/3.0.8 }
+ Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.12 }
Constant [ null http\Client\Curl\Versions\ARES ] { }
- Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.2 }
+ Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.4 }
Constant [ null http\Client\Curl\Versions\ICONV ] { }
Constant [ string http\Client\Curl\Versions\BROTLI ] { 1.0.9 }
- Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.45.1 }
+ Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.51.0 }
Constant [ null http\Client\Curl\Versions\QUIC ] { }
Constant [ string http\Client\Curl\Versions\CAINFO ] { /etc/pki/tls/certs/ca-bundle.crt }
Constant [ null http\Client\Curl\Versions\CAPATH ] { }
@@ -138,8 +138,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -156,6 +156,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -229,8 +230,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -247,6 +248,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -320,8 +322,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -338,6 +340,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -411,8 +414,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -429,6 +432,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -502,8 +506,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -520,6 +524,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -593,8 +598,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -611,6 +616,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -684,8 +690,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -702,6 +708,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -775,8 +782,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -793,6 +800,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -866,8 +874,8 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -884,6 +892,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1885,6 +1894,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, prototype Serializable> public method serialize ] {
@@ -1919,30 +1929,35 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ http\Message ]
}
Method [ <internal:http, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype Stringable> public method __toString ] {
@@ -2176,7 +2191,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
Class [ <internal:http> <iterateable> class http\QueryString implements Stringable, Serializable, ArrayAccess, IteratorAggregate, Traversable ] {
- Constants [6] {
- Constant [ public int TYPE_BOOL ] { 17 }
+ Constant [ public int TYPE_BOOL ] { 18 }
Constant [ public int TYPE_INT ] { 4 }
Constant [ public int TYPE_FLOAT ] { 5 }
Constant [ public int TYPE_STRING ] { 6 }
@@ -2345,6 +2360,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetSet ] {
@@ -2353,6 +2369,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
Parameter #0 [ <required> $name ]
Parameter #1 [ <required> $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetExists ] {
@@ -2360,6 +2377,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetUnset ] {
@@ -2367,6 +2385,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ void ]
}
}
}
@@ -2442,6 +2461,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http> public method send ] {
@@ -2503,6 +2523,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
Parameter #0 [ <optional> ?http\Client\Request $request = <default> ]
Parameter #1 [ <optional> $progress = <default> ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype SplSubject> public method attach ] {
@@ -2510,6 +2531,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> SplObserver $observer ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype SplSubject> public method detach ] {
@@ -2517,6 +2539,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> SplObserver $observer ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http> public method getObservers ] {
@@ -2905,6 +2928,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Serializable> public method serialize ] {
@@ -2939,30 +2963,35 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ http\Message ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Stringable> public method __toString ] {
@@ -3246,6 +3275,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Serializable> public method serialize ] {
@@ -3280,30 +3310,35 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ http\Message ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Stringable> public method __toString ] {
@@ -3960,6 +3995,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Serializable> public method serialize ] {
@@ -3994,30 +4030,35 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ http\Message ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Stringable> public method __toString ] {
@@ -4391,6 +4432,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Serializable> public method serialize ] {
@@ -4425,30 +4467,35 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method valid ] {
- Parameters [0] {
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method current ] {
- Parameters [0] {
}
+ - Tentative return [ http\Message ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method key ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:http, inherits http\Message, prototype Iterator> public method next ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:http, inherits http\Message, prototype Stringable> public method __toString ] {
@@ -4560,6 +4607,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetUnset ] {
@@ -4567,6 +4615,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetSet ] {
@@ -4575,6 +4624,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
Parameter #0 [ <required> $name ]
Parameter #1 [ <required> $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:http, prototype ArrayAccess> public method offsetGet ] {
@@ -4582,6 +4632,7 @@ Extension [ <persistent> extension #109 http version 4.2.3 ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
+ - Tentative return [ mixed ]
}
}
}
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 1d26ceb..862df9a 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,14 +3,13 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2012-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-http
%else
%global _root_prefix %{_prefix}
@@ -40,18 +39,18 @@
#global upstream_prever beta1
#global upstream_lower beta1
-Name: %{?sub_prefix}php-pecl-http
+Name: %{?scl_prefix}php-pecl-http
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
-License: BSD
+License: BSD-2-Clause
URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
@@ -62,11 +61,10 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-spl
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: pcre-devel
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-# We require 69 to ensure we use the same version than PHP
-BuildRequires: pkgconfig(icu-i18n) >= 71
+# We require 72 to ensure we use the same version than PHP
+BuildRequires: pkgconfig(icu-i18n) >= 72
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
@@ -89,25 +87,11 @@ Obsoletes: %{?scl_prefix}php-pecl-propro < 2.2
Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
-%endif
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php73-pecl-http <= %{version}
-Obsoletes: php74-pecl-http <= %{version}
-Obsoletes: php80-pecl-http <= %{version}
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-http <= %{version}
-%endif
-%endif
-
%description
The HTTP extension aims to provide a convenient and powerful set of
@@ -131,10 +115,6 @@ Summary: Extended HTTP support developer files (header)
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa} >= 5.3.0
Obsoletes: %{?scl_prefix}php-pecl-http1-devel < 2
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}
-%endif
%description devel
These are the files needed to compile programs using HTTP extension.
@@ -237,6 +217,7 @@ done
: ignore tests with erratic results
rm ?TS/tests/client021.phpt
rm ?TS/tests/client022.phpt
+rm ?TS/tests/client025.phpt
rm ?TS/tests/client027.phpt
export REPORT_EXIT_STATUS=1
@@ -335,6 +316,10 @@ fi
%changelog
+* Thu May 11 2023 Remi Collet <remi@remirepo.net> - 4.2.3-3
+- rebuild using ICU 72
+- use SPDX license ID
+
* Tue Sep 6 2022 Remi Collet <remi@remirepo.net> - 4.2.3-2
- rebuild using ICU 71