summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-03 11:23:29 +0100
committerRemi Collet <remi@remirepo.net>2020-12-03 11:23:29 +0100
commit365d6a7437d60f84653ceb68f8b33db05127182e (patch)
treed59fabf4f0e08129297c709379cd949d0a4c2cee
parent9ebcbe8204e99f6617c791ec8a851589bb9f3cb8 (diff)
EL-7: add dependency on brotli
obsolete propro to allow upgrade from 7.x
-rw-r--r--php-pecl-http.spec27
1 files changed, 11 insertions, 16 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index f7e34ea..d70ff23 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -16,12 +16,7 @@
%global _root_prefix %{_prefix}
%endif
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global with_libbrotli 1
-%else
-%global with_libbrotli 0
-%endif
-
+%bcond_without libbrotli
%global gh_commit a84b499418ee7b8992fd9e7e2abc661735a869bd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -51,7 +46,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -75,15 +70,17 @@ BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
BuildRequires: openssl-devel
-%if %{?with_libbrotli}
+%if %{with libbrotli}
BuildRequires: brotli-devel >= 1.0
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-spl%{?_isa}
-Requires: %{?scl_prefix}php-pecl(raphf)%{?_isa} >= 2
+Requires: %{?scl_prefix}php-raphf%{?_isa} >= 2
Obsoletes: %{?scl_prefix}php-pecl-http1 < 2
+# to allow migration from PHP 7 (last is 2.1.0)
+Obsoletes: %{?scl_prefix}php-pecl-propro < 2.2
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
@@ -104,12 +101,6 @@ Obsoletes: php74-pecl-http <= %{version}
Obsoletes: php80-pecl-http <= %{version}
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%endif
-%{?filter_setup}
-
%description
The HTTP extension aims to provide a convenient and powerful set of
@@ -187,7 +178,7 @@ peclconf() {
--without-http-libidnkit2-dir \
--with-http-libicu-dir=%{_root_prefix} \
--with-http-libevent-dir=%{_root_prefix} \
-%if %{?with_libbrotli}
+%if %{with libbrotli}
--with-http-libbrotli-dir=%{_root_prefix} \
%endif
--with-libdir=%{_lib} \
@@ -338,6 +329,10 @@ fi
%changelog
+* Thu Dec 3 2020 Remi Collet <remi@remirepo.net> - 4.0.0~beta1-3
+- EL-7: add dependency on brotli
+- obsolete propro to allow upgrade from 7.x
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 4.0.0~beta1-2
- rebuild for PHP 8.0.0RC1