summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-11 16:07:03 +0200
committerRemi Collet <remi@php.net>2023-05-11 16:07:03 +0200
commit5c5814842ba377370a427bb471ce0a0f49b5e9ec (patch)
treef16c4e5e063ff91e59c351692384883fcbbcf937
parent598b8e435c91dd6343362877ca81c8186d8fa713 (diff)
rebuild using ICU 72php7
use SPDX license ID
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-http.spec57
3 files changed, 28 insertions, 51 deletions
diff --git a/PHPINFO b/PHPINFO
index 848af79..a83e99e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,10 +5,10 @@ HTTP Support => enabled
Extension Version => 3.3.0
Used Library => Compiled => Linked
-libz => 1.2.11 => 1.2.11
-libcurl => 7.79.1 => 7.79.1
+libz => 1.2.12 => 1.2.12
+libcurl => 7.85.0 => 7.85.0
libevent => 2.1.12-stable => 2.1.12-stable
-libicu (IDNA2008/IDNA2003) => 69.1 => 69.1
+libicu (IDNA2008/IDNA2003) => 72.1 => 72.1
libidn2 (IDNA2008) => disabled => disabled
libidn (IDNA2003) => disabled => disabled
libidnkit2 (IDNA2008) => disabled => disabled
diff --git a/REFLECTION b/REFLECTION
index 7db98d5..e5a68f9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #154 http version 3.3.0 ] {
+Extension [ <persistent> extension #151 http version 3.3.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #154 http version 3.3.0 ] {
}
- Constants [91] {
- Constant [ int http\Client\Curl\FEATURES ] { 297781149 }
+ Constant [ int http\Client\Curl\FEATURES ] { 1371522973 }
Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
Constant [ int http\Client\Curl\Features\SSL ] { 4 }
@@ -41,15 +41,15 @@ Extension [ <persistent> extension #154 http version 3.3.0 ] {
Constant [ int http\Client\Curl\Features\ZSTD ] { 67108864 }
Constant [ int http\Client\Curl\Features\UNICODE ] { 134217728 }
Constant [ int http\Client\Curl\Features\HSTS ] { 268435456 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.79.1 OpenSSL/1.1.1n-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.45.1 OpenLDAP/2.4.59 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.79.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1n-fips }
- Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.85.0 OpenSSL/3.0.8 zlib/1.2.12 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.3) libssh/0.10.4/openssl/zlib nghttp2/1.51.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.85.0 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/3.0.8 }
+ Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.12 }
Constant [ null http\Client\Curl\Versions\ARES ] { }
- Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.2 }
+ Constant [ string http\Client\Curl\Versions\IDN ] { 2.3.4 }
Constant [ null http\Client\Curl\Versions\ICONV ] { }
Constant [ string http\Client\Curl\Versions\BROTLI ] { 1.0.9 }
- Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.45.1 }
+ Constant [ string http\Client\Curl\Versions\NGHTTP2 ] { 1.51.0 }
Constant [ null http\Client\Curl\Versions\QUIC ] { }
Constant [ string http\Client\Curl\Versions\CAINFO ] { /etc/pki/tls/certs/ca-bundle.crt }
Constant [ null http\Client\Curl\Versions\CAPATH ] { }
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index e0a31e5..4174722 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,14 +3,13 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2012-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-http
%else
%global _root_prefix %{_prefix}
@@ -32,26 +31,26 @@
%global ini_name 50-%{pecl_name}.ini
%ifarch %{arm}
# Test suite disabled because of erratic results on slow ARM (timeout)
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
%global upstream_version 3.3.0
#global upstream_prever RC1
-Name: %{?sub_prefix}php-pecl-http
+Name: %{?scl_prefix}php-pecl-http
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date:1}
Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
-License: BSD
+License: BSD-2-Clause
URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
@@ -59,14 +58,15 @@ Source1: %{proj_name}.ini
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-devel < 8
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-spl
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-# Use same version than PHP to ensure we use libicu65
-BuildRequires: pkgconfig(icu-i18n) >= 65
+# Use same version than PHP to ensure we use libicu72
+BuildRequires: pkgconfig(icu-i18n) >= 72
BuildRequires: %{?scl_prefix}php-pecl-propro-devel >= 2
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
@@ -87,35 +87,11 @@ Obsoletes: %{?scl_prefix}php-pecl-http1 < 2
Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
-%endif
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-http <= %{version}
-Obsoletes: php71w-pecl-http <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-http <= %{version}
-Obsoletes: php72w-pecl-http <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-http <= %{version}
-Obsoletes: php73w-pecl-http <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-http <= %{version}
-Obsoletes: php74w-pecl-http <= %{version}
-%endif
-%endif
-
%description
The HTTP extension aims to provide a convenient and powerful set of
@@ -139,10 +115,6 @@ Summary: Extended HTTP support developer files (header)
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa} >= 5.3.0
Obsoletes: %{?scl_prefix}php-pecl-http1-devel < 2
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}
-%endif
%description devel
These are the files needed to compile programs using HTTP extension.
@@ -244,6 +216,7 @@ done
%check
# TODO see https://github.com/m6w6/ext-http/issues/91
rm ?TS/tests/client021.phpt
+rm ?TS/tests/client025.phpt
rm ?TS/tests/client027.phpt
rm ?TS/tests/client031.phpt
rm ?TS/tests/client032.phpt
@@ -275,7 +248,7 @@ done
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite NTS extension
cd NTS
TEST_PHP_EXECUTABLE=%{__php} \
@@ -291,7 +264,7 @@ NO_INTERACTION=1 \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite ZTS extension
cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
@@ -345,6 +318,10 @@ fi
%changelog
+* Thu May 11 2023 Remi Collet <remi@remirepo.net> - 4.2.3-3
+- rebuild using ICU 72
+- use SPDX license ID
+
* Fri Jun 10 2022 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0