summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION952
-rw-r--r--php-pecl-http-message.spec239
5 files changed, 1206 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..0e6b2fb
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+http_message
+
+Version => 0.1.0
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..9333a3d
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,952 @@
+Extension [ <persistent> extension #191 http_message version 0.1.0 ] {
+
+ - Dependencies {
+ Dependency [ psr (Required) ]
+ }
+
+ - Classes [7] {
+ Class [ <internal:http_message> abstract class HttpMessage\Message implements Psr\Http\Message\MessageInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> protected $protocolVersion ]
+ Property [ <default> protected $headers ]
+ Property [ <default> protected $body ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:http_message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method getProtocolVersion ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method withProtocolVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $version ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method hasHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method getHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method getHeaderLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method withHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method withAddedHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method withoutHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method getBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\MessageInterface> public method withBody ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\Request extends HttpMessage\Message implements Psr\Http\Message\MessageInterface, Psr\Http\Message\RequestInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [6] {
+ Property [ <default> protected $protocolVersion ]
+ Property [ <default> protected $headers ]
+ Property [ <default> protected $body ]
+ Property [ <default> protected $requestTarget ]
+ Property [ <default> protected $method ]
+ Property [ <default> protected $uri ]
+ }
+
+ - Methods [18] {
+ Method [ <internal:http_message, overwrites HttpMessage\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method getRequestTarget ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method withRequestTarget ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $requestTarget ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method getMethod ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method withMethod ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $method ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method getUri ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method withUri ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Psr\Http\Message\UriInterface $logger ]
+ Parameter #1 [ <optional> $preserveHost ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getProtocolVersion ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withProtocolVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $version ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method hasHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaderLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withAddedHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withoutHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withBody ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\ServerRequest extends HttpMessage\Request implements Psr\Http\Message\RequestInterface, Psr\Http\Message\MessageInterface, Psr\Http\Message\ServerRequestInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [12] {
+ Property [ <default> protected $protocolVersion ]
+ Property [ <default> protected $headers ]
+ Property [ <default> protected $body ]
+ Property [ <default> protected $requestTarget ]
+ Property [ <default> protected $method ]
+ Property [ <default> protected $uri ]
+ Property [ <default> protected $serverParams ]
+ Property [ <default> protected $cookieParams ]
+ Property [ <default> protected $queryParams ]
+ Property [ <default> protected $uploadedFiles ]
+ Property [ <default> protected $parsedBody ]
+ Property [ <default> protected $attributes ]
+ }
+
+ - Methods [31] {
+ Method [ <internal:http_message, overwrites HttpMessage\Request, ctor> public method __construct ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <optional> array $serverParams ]
+ Parameter #1 [ <optional> array $cookieParams ]
+ Parameter #2 [ <optional> array $queryParams ]
+ Parameter #3 [ <optional> array $postParams ]
+ Parameter #4 [ <optional> array $files ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getServerParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getCookieParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withCookieParams ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $cookies ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getQueryParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withQueryParams ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $query ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getUploadedFiles ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withUploadedFiles ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $uploadedFiles ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getParsedBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withParsedBody ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $parsedBody ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getAttributes ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method getAttribute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withAttribute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestInterface> public method withoutAttribute ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method getRequestTarget ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method withRequestTarget ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $requestTarget ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method getMethod ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method withMethod ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $method ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method getUri ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method withUri ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Psr\Http\Message\UriInterface $logger ]
+ Parameter #1 [ <optional> $preserveHost ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getProtocolVersion ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withProtocolVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $version ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method hasHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaderLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withAddedHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withoutHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withBody ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\Response extends HttpMessage\Message implements Psr\Http\Message\MessageInterface, Psr\Http\Message\ResponseInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $protocolVersion ]
+ Property [ <default> protected $headers ]
+ Property [ <default> protected $body ]
+ Property [ <default> protected $statusCode ]
+ Property [ <default> protected $reasonPhrase ]
+ }
+
+ - Methods [15] {
+ Method [ <internal:http_message, prototype Psr\Http\Message\ResponseInterface> public method getStatusCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ResponseInterface> public method getReasonPhrase ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ResponseInterface> public method withStatus ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $code ]
+ Parameter #1 [ <optional> $reasonPhrase ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getProtocolVersion ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withProtocolVersion ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $version ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method hasHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getHeaderLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withAddedHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withoutHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method getBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, inherits HttpMessage\Message, prototype Psr\Http\Message\MessageInterface> public method withBody ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $body ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\Stream implements Psr\Http\Message\StreamInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $stream ]
+ }
+
+ - Methods [16] {
+ Method [ <internal:http_message, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> resource $uri ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method detach ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method getSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method tell ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method eof ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method isSeekable ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method seek ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <optional> $whence ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method isWritable ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method write ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method isReadable ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method read ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $length ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method getContents ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamInterface> public method getMetadata ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $key ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\Uri implements Psr\Http\Message\UriInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [7] {
+ Property [ <default> protected $scheme ]
+ Property [ <default> protected $userInfo ]
+ Property [ <default> protected $host ]
+ Property [ <default> protected $port ]
+ Property [ <default> protected $path ]
+ Property [ <default> protected $query ]
+ Property [ <default> protected $fragment ]
+ }
+
+ - Methods [17] {
+ Method [ <internal:http_message, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string $uri ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getScheme ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withScheme ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $scheme ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getAuthority ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getUserInfo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withUserInfo ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $user ]
+ Parameter #1 [ <optional> $password ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withHost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $host ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withPort ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $port ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getPath ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withPath ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $path ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getQuery ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withQuery ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $query ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method getFragment ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriInterface> public method withFragment ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fragment ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:http_message> class HttpMessage\UploadedFile implements Psr\Http\Message\UploadedFileInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [8] {
+ Property [ <default> protected $stream ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $size ]
+ Property [ <default> protected $error ]
+ Property [ <default> protected $clientFilename ]
+ Property [ <default> protected $clientMediaType ]
+ Property [ <default> protected $moved ]
+ Property [ <default> protected $checkUploaded ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:http_message, ctor> public method &__construct ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> string or NULL $file ]
+ Parameter #1 [ <optional> integer or NULL $size ]
+ Parameter #2 [ <optional> integer $error ]
+ Parameter #3 [ <optional> string or NULL $clientFilename ]
+ Parameter #4 [ <optional> string or NULL $clientMediaType ]
+ Parameter #5 [ <optional> $checkUploaded ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method getStream ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method moveTo ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $targetPath ]
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method getSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method getError ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method getClientFilename ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileInterface> public method getClientMediaType ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-http-message.spec b/php-pecl-http-message.spec
new file mode 100644
index 0000000..e661019
--- /dev/null
+++ b/php-pecl-http-message.spec
@@ -0,0 +1,239 @@
+# remirepo spec file for php-pecl-http-message
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-http-message
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name http_message
+%global with_tests 0%{!?_without_tests:1}
+# after 40-psr.ini
+%global ini_name 50-%{pecl_name}.ini
+#global prever RC2
+
+Summary: PSR-7 HTTP Message implementation
+Name: %{?sub_prefix}php-pecl-http-message
+Version: 0.1.0
+Release: 11%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7.2
+BuildRequires: %{?scl_prefix}php-pecl-psr-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-psr%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PSR-7 compatible HTTP Message implementation as PHP extension.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%package devel
+Summary: %{name} developer files (headers)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
+
+%description devel
+These are the files needed to compile programs using %{name}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version}%{?prever} NTS
+
+# Don't install/register tests
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_HTTP_MESSAGE_VERSION/{s/.* "//;s/".*$//;p}' php_http_message.h)
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-http-message \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-http-message \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Tests & Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+OPT="-n -d extension=psr"
+
+cd NTS
+: Minimal load test for NTS extension
+%{__php} $OPT \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} $OPT \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="$OPT -d extension=$PWD/modules/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php -q --show-diff
+%endif
+%endif
+
+
+%files
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%files devel
+%doc %{pecl_testdir}/%{pecl_name}
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Thu Jul 11 2019 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- initial package