summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-05 07:30:36 +0200
committerRemi Collet <remi@remirepo.net>2019-09-05 07:30:36 +0200
commitce157c4f0968237e879df689a7092cefa2daba7f (patch)
tree6b4c7ef90484e383ec9a25e66319ff5a36a6c021
parent2788542cbb4c0d51ff99cfc44896e4fdf18a0a36 (diff)
v0.2.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION182
-rw-r--r--php-pecl-http-message.spec7
3 files changed, 136 insertions, 55 deletions
diff --git a/PHPINFO b/PHPINFO
index 40db566..451cdcc 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,4 +1,4 @@
http_message
-Version => 0.1.1
+Version => 0.2.0
diff --git a/REFLECTION b/REFLECTION
index 6cd3bf9..a8b5afb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,10 +1,10 @@
-Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
+Extension [ <persistent> extension #191 http_message version 0.2.0 ] {
- Dependencies {
Dependency [ psr (Required) ]
}
- - Classes [7] {
+ - Classes [8] {
Class [ <internal:http_message> abstract class HttpMessage\Message implements Psr\Http\Message\MessageInterface ] {
- Constants [0] {
@@ -17,9 +17,9 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
}
- Properties [3] {
- Property [ <default> protected $protocolVersion ]
- Property [ <default> protected $headers ]
- Property [ <default> protected $body ]
+ Property [ <default> private $protocolVersion ]
+ Property [ <default> private $headers ]
+ Property [ <default> private $body ]
}
- Methods [12] {
@@ -118,13 +118,10 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
- Static methods [0] {
}
- - Properties [6] {
- Property [ <default> protected $protocolVersion ]
- Property [ <default> protected $headers ]
- Property [ <default> protected $body ]
- Property [ <default> protected $requestTarget ]
- Property [ <default> protected $method ]
- Property [ <default> protected $uri ]
+ - Properties [3] {
+ Property [ <default> private $requestTarget ]
+ Property [ <default> private $method ]
+ Property [ <default> private $uri ]
}
- Methods [18] {
@@ -169,7 +166,7 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
Method [ <internal:http_message, prototype Psr\Http\Message\RequestInterface> public method withUri ] {
- Parameters [2] {
- Parameter #0 [ <required> Psr\Http\Message\UriInterface $logger ]
+ Parameter #0 [ <required> Psr\Http\Message\UriInterface $uri ]
Parameter #1 [ <optional> $preserveHost ]
}
}
@@ -263,19 +260,13 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
- Static methods [0] {
}
- - Properties [12] {
- Property [ <default> protected $protocolVersion ]
- Property [ <default> protected $headers ]
- Property [ <default> protected $body ]
- Property [ <default> protected $requestTarget ]
- Property [ <default> protected $method ]
- Property [ <default> protected $uri ]
- Property [ <default> protected $serverParams ]
- Property [ <default> protected $cookieParams ]
- Property [ <default> protected $queryParams ]
- Property [ <default> protected $uploadedFiles ]
- Property [ <default> protected $parsedBody ]
- Property [ <default> protected $attributes ]
+ - Properties [6] {
+ Property [ <default> private $serverParams ]
+ Property [ <default> private $cookieParams ]
+ Property [ <default> private $queryParams ]
+ Property [ <default> private $uploadedFiles ]
+ Property [ <default> private $parsedBody ]
+ Property [ <default> private $attributes ]
}
- Methods [31] {
@@ -412,7 +403,7 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
Method [ <internal:http_message, inherits HttpMessage\Request, prototype Psr\Http\Message\RequestInterface> public method withUri ] {
- Parameters [2] {
- Parameter #0 [ <required> Psr\Http\Message\UriInterface $logger ]
+ Parameter #0 [ <required> Psr\Http\Message\UriInterface $uri ]
Parameter #1 [ <optional> $preserveHost ]
}
}
@@ -506,12 +497,9 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
- Static methods [0] {
}
- - Properties [5] {
- Property [ <default> protected $protocolVersion ]
- Property [ <default> protected $headers ]
- Property [ <default> protected $body ]
- Property [ <default> protected $statusCode ]
- Property [ <default> protected $reasonPhrase ]
+ - Properties [2] {
+ Property [ <default> private $statusCode ]
+ Property [ <default> private $reasonPhrase ]
}
- Methods [15] {
@@ -631,14 +619,14 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
}
- Properties [1] {
- Property [ <default> protected $stream ]
+ Property [ <default> private $stream ]
}
- Methods [16] {
Method [ <internal:http_message, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> resource $uri ]
+ Parameter #0 [ <optional> $uri ]
}
}
@@ -751,13 +739,13 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
}
- Properties [7] {
- Property [ <default> protected $scheme ]
- Property [ <default> protected $userInfo ]
- Property [ <default> protected $host ]
- Property [ <default> protected $port ]
- Property [ <default> protected $path ]
- Property [ <default> protected $query ]
- Property [ <default> protected $fragment ]
+ Property [ <default> private $scheme ]
+ Property [ <default> private $userInfo ]
+ Property [ <default> private $host ]
+ Property [ <default> private $port ]
+ Property [ <default> private $path ]
+ Property [ <default> private $query ]
+ Property [ <default> private $fragment ]
}
- Methods [17] {
@@ -886,21 +874,21 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
}
- Properties [8] {
- Property [ <default> protected $stream ]
- Property [ <default> protected $file ]
- Property [ <default> protected $size ]
- Property [ <default> protected $error ]
- Property [ <default> protected $clientFilename ]
- Property [ <default> protected $clientMediaType ]
- Property [ <default> protected $moved ]
- Property [ <default> protected $checkUploaded ]
+ Property [ <default> private $stream ]
+ Property [ <default> private $file ]
+ Property [ <default> private $size ]
+ Property [ <default> private $error ]
+ Property [ <default> private $clientFilename ]
+ Property [ <default> private $clientMediaType ]
+ Property [ <default> private $moved ]
+ Property [ <default> private $checkUploaded ]
}
- Methods [7] {
- Method [ <internal:http_message, ctor> public method &__construct ] {
+ Method [ <internal:http_message, ctor> public method __construct ] {
- Parameters [6] {
- Parameter #0 [ <optional> string or NULL $file ]
+ Parameter #0 [ <required> $fileOrStream ]
Parameter #1 [ <optional> integer or NULL $size ]
Parameter #2 [ <optional> integer $error ]
Parameter #3 [ <optional> string or NULL $clientFilename ]
@@ -947,6 +935,96 @@ Extension [ <persistent> extension #191 http_message version 0.1.1 ] {
}
}
}
+
+ Class [ <internal:http_message> class HttpMessage\Factory implements Psr\Http\Message\RequestFactoryInterface, Psr\Http\Message\ResponseFactoryInterface, Psr\Http\Message\ServerRequestFactoryInterface, Psr\Http\Message\StreamFactoryInterface, Psr\Http\Message\UploadedFileFactoryInterface, Psr\Http\Message\UriFactoryInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [8] {
+ Method [ <internal:http_message, prototype Psr\Http\Message\RequestFactoryInterface> public method createRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> $uri ]
+ }
+ - Return [ Psr\Http\Message\RequestInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ResponseFactoryInterface> public method createResponse ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> integer $code ]
+ Parameter #1 [ <optional> string $reasonPhrase ]
+ }
+ - Return [ Psr\Http\Message\ResponseInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\ServerRequestFactoryInterface> public method createServerRequest ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> $uri ]
+ Parameter #2 [ <optional> array $serverParams ]
+ }
+ - Return [ Psr\Http\Message\ServerRequestInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamFactoryInterface> public method createStream ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string $content ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamFactoryInterface> public method createStreamFromFile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $filename ]
+ Parameter #1 [ <optional> string $mode ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\StreamFactoryInterface> public method createStreamFromResource ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $resouce ]
+ }
+ - Return [ Psr\Http\Message\StreamInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UploadedFileFactoryInterface> public method createUploadedFile ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> Psr\Http\Message\StreamInterface $stream ]
+ Parameter #1 [ <optional> integer or NULL $size ]
+ Parameter #2 [ <optional> integer $error ]
+ Parameter #3 [ <optional> string or NULL $clientFilename ]
+ Parameter #4 [ <optional> string or NULL $clientMediaType ]
+ }
+ - Return [ Psr\Http\Message\UploadedFileInterface ]
+ }
+
+ Method [ <internal:http_message, prototype Psr\Http\Message\UriFactoryInterface> public method createUri ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string $uri ]
+ }
+ - Return [ Psr\Http\Message\UriInterface ]
+ }
+ }
+ }
}
}
diff --git a/php-pecl-http-message.spec b/php-pecl-http-message.spec
index bddbd2f..519e555 100644
--- a/php-pecl-http-message.spec
+++ b/php-pecl-http-message.spec
@@ -20,8 +20,8 @@
Summary: PSR-7 HTTP Message implementation
Name: %{?sub_prefix}php-pecl-http-message
-Version: 0.1.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.2.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -235,6 +235,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Sep 5 2019 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.1.1-2
- rebuild for 7.4.0RC1