summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-05 17:39:54 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-05 17:39:54 +0100
commita726f1b9d2c8f7dbeba7930bdb96c37eed94119d (patch)
tree225524adcc1e774dbf1c5d19ce38c2df77b537ec
parent434c0a4ca2a1108cd413d8a664131d6c2287fb2d (diff)
php-pecl-hrtime: F24
-rw-r--r--php-pecl-hrtime.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-pecl-hrtime.spec b/php-pecl-hrtime.spec
index 2f1de02..af97e5f 100644
--- a/php-pecl-hrtime.spec
+++ b/php-pecl-hrtime.spec
@@ -15,9 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-hrtime}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name hrtime
@@ -30,7 +27,7 @@
Summary: High resolution timing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.5.1
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -44,10 +41,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -90,7 +89,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
# Sanity check, really often broken
@@ -154,6 +155,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -170,6 +172,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -225,6 +228,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 0.5.1-7
+- adapt for F24
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 0.5.1-6
- rebuild for PHP 7.0.0RC5 new API version