summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-06 05:55:37 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-06 05:55:37 +0100
commit4224414a61091780824ad12b9b0cefe2f30f30cc (patch)
tree3b4ab9aabdead92f3791f8d3d5051a84c46cbb91
parent8938b89513d03095f38a33784c873bb4d420bab4 (diff)
php-pecl-hrtime: 0.6.0
-rw-r--r--REFLECTION56
-rw-r--r--php-pecl-hrtime.spec18
2 files changed, 38 insertions, 36 deletions
diff --git a/REFLECTION b/REFLECTION
index 10667b8..c0941d3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #96 hrtime version 0.5.1 ] {
+Extension [ <persistent> extension #95 hrtime version 0.6.0 ] {
- Classes [3] {
Class [ <internal:hrtime> class HRTime\PerformanceCounter ] {
@@ -9,30 +9,21 @@ Extension [ <persistent> extension #96 hrtime version 0.5.1 ] {
- Static properties [0] {
}
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [6] {
- Method [ <internal:hrtime> public method start ] {
- }
-
- Method [ <internal:hrtime> public method stop ] {
+ - Static methods [3] {
+ Method [ <internal:hrtime> static public method getFrequency ] {
}
- Method [ <internal:hrtime> public method getElapsedTicks ] {
+ Method [ <internal:hrtime> static public method getTicks ] {
}
- Method [ <internal:hrtime> public method getLastElapsedTicks ] {
+ Method [ <internal:hrtime> static public method getTicksSince ] {
}
+ }
- Method [ <internal:hrtime> public method getFrequency ] {
- }
+ - Properties [0] {
+ }
- Method [ <internal:hrtime> public method isRunning ] {
- }
+ - Methods [0] {
}
}
@@ -44,35 +35,40 @@ Extension [ <persistent> extension #96 hrtime version 0.5.1 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [3] {
+ Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> static public method getFrequency ] {
+ }
+
+ Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> static public method getTicks ] {
+ }
+
+ Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> static public method getTicksSince ] {
+ }
}
- Properties [0] {
}
- - Methods [8] {
- Method [ <internal:hrtime> public method getElapsedTime ] {
- }
-
- Method [ <internal:hrtime> public method getLastElapsedTime ] {
+ - Methods [7] {
+ Method [ <internal:hrtime> public method start ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method start ] {
+ Method [ <internal:hrtime> public method stop ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method stop ] {
+ Method [ <internal:hrtime> public method getElapsedTicks ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method getElapsedTicks ] {
+ Method [ <internal:hrtime> public method getLastElapsedTicks ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method getLastElapsedTicks ] {
+ Method [ <internal:hrtime> public method isRunning ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method getFrequency ] {
+ Method [ <internal:hrtime> public method getElapsedTime ] {
}
- Method [ <internal:hrtime, inherits HRTime\PerformanceCounter> public method isRunning ] {
+ Method [ <internal:hrtime> public method getLastElapsedTime ] {
}
}
}
diff --git a/php-pecl-hrtime.spec b/php-pecl-hrtime.spec
index 689958c..254416e 100644
--- a/php-pecl-hrtime.spec
+++ b/php-pecl-hrtime.spec
@@ -21,8 +21,8 @@
Summary: High resolution timing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.5.1
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.6.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -40,8 +40,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -114,6 +116,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -130,10 +134,10 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
rm -rf %{buildroot}
-make -C NTS \
- install INSTALL_ROOT=%{buildroot}
+make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -142,8 +146,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS \
- install INSTALL_ROOT=%{buildroot}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -227,6 +230,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jan 6 2017 Remi Collet <remi@fedoraproject.org> - 0.6.0-1
+- Update to 0.6.0
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.5.1-9
- rebuild with PHP 7.1.0 GA