summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-05 15:46:21 +0200
committerRemi Collet <remi@remirepo.net>2019-06-05 15:46:21 +0200
commiteaa92794c21b4a3fb8d5078a5709037aa1e053b0 (patch)
tree5d03775bea57cf3294166461172fdd2140183758
parent213208e00c82f0866a34039669a037c0f1d253b4 (diff)
- update to 1.6.7
- drop patch merged upstream
-rw-r--r--14.patch51
-rw-r--r--REFLECTION70
-rw-r--r--php-pecl-hprose.spec28
3 files changed, 47 insertions, 102 deletions
diff --git a/14.patch b/14.patch
deleted file mode 100644
index 0191414..0000000
--- a/14.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 42e38feb2bd06b0504d0a5efe2f22de332b8de9d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 26 Jun 2018 10:10:48 +0200
-Subject: [PATCH] fix for PHP 7.3
-
----
- hprose_common.c | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/hprose_common.c b/hprose_common.c
-index f7ecdde..a2de5f5 100644
---- a/hprose_common.c
-+++ b/hprose_common.c
-@@ -158,12 +158,15 @@ zend_fcall_info_cache __get_fcall_info_cache(zval *obj, char *name, int32_t len
- lcname = zend_str_tolower_dup(fname, flen);
- #if PHP_MAJOR_VERSION < 7
- if (zend_hash_find(&ce->function_table, lcname, flen + 1, (void **) &fptr) == FAILURE) {
-+ efree(lcname);
-+ zend_throw_exception_ex(NULL, 0 TSRMLS_CC,
-+ "Method %s::%s() does not exist", ce->name, fname);
- #else
- if ((fptr = zend_hash_str_find_ptr(&ce->function_table, lcname, flen)) == NULL) {
--#endif
- efree(lcname);
- zend_throw_exception_ex(NULL, 0 TSRMLS_CC,
-- "Method %s::%s() does not exist", ce->name, fname);
-+ "Method %s::%s() does not exist", ZSTR_VAL(ce->name), fname);
-+#endif
- return fcc;
- }
- fcc.function_handler = fptr;
-@@ -199,7 +202,9 @@ zend_fcall_info_cache __get_fcall_info_cache(zval *obj, char *name, int32_t len
- if (lcname) {
- efree(lcname);
- }
-+#if PHP_VERSION_ID < 70300
- fcc.initialized = 1;
-+#endif
- return fcc;
- }
-
-@@ -761,7 +766,9 @@ zend_class_entry *__create_php_object(char *class_name, int32_t len, zval *retur
- fci.params = params;
- fci.no_separation = 1;
-
-+#if PHP_VERSION_ID < 70300
- fcc.initialized = 1;
-+#endif
- fcc.function_handler = constructor;
- fcc.calling_scope = scope;
- fcc.called_scope = Z_OBJCE_P(return_value);
diff --git a/REFLECTION b/REFLECTION
index 8f56b4f..faa6d1a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #94 hprose version 1.6.6 ] {
+Extension [ <persistent> extension #103 hprose version 1.6.7 ] {
- Functions {
Function [ <internal:hprose> function hprose_serialize ] {
@@ -26,40 +26,40 @@ Extension [ <persistent> extension #94 hprose version 1.6.6 ] {
Class [ <internal:hprose> class Hprose\Tags ] {
- Constants [34] {
- Constant [ string TagInteger ] { i }
- Constant [ string TagLong ] { l }
- Constant [ string TagDouble ] { d }
- Constant [ string TagNull ] { n }
- Constant [ string TagEmpty ] { e }
- Constant [ string TagTrue ] { t }
- Constant [ string TagFalse ] { f }
- Constant [ string TagNaN ] { N }
- Constant [ string TagInfinity ] { I }
- Constant [ string TagDate ] { D }
- Constant [ string TagTime ] { T }
- Constant [ string TagUTC ] { Z }
- Constant [ string TagBytes ] { b }
- Constant [ string TagUTF8Char ] { u }
- Constant [ string TagString ] { s }
- Constant [ string TagGuid ] { g }
- Constant [ string TagList ] { a }
- Constant [ string TagMap ] { m }
- Constant [ string TagClass ] { c }
- Constant [ string TagObject ] { o }
- Constant [ string TagRef ] { r }
- Constant [ string TagPos ] { + }
- Constant [ string TagNeg ] { - }
- Constant [ string TagSemicolon ] { ; }
- Constant [ string TagOpenbrace ] { { }
- Constant [ string TagClosebrace ] { } }
- Constant [ string TagQuote ] { " }
- Constant [ string TagPoint ] { . }
- Constant [ string TagFunctions ] { F }
- Constant [ string TagCall ] { C }
- Constant [ string TagResult ] { R }
- Constant [ string TagArgument ] { A }
- Constant [ string TagError ] { E }
- Constant [ string TagEnd ] { z }
+ Constant [ public string TagInteger ] { i }
+ Constant [ public string TagLong ] { l }
+ Constant [ public string TagDouble ] { d }
+ Constant [ public string TagNull ] { n }
+ Constant [ public string TagEmpty ] { e }
+ Constant [ public string TagTrue ] { t }
+ Constant [ public string TagFalse ] { f }
+ Constant [ public string TagNaN ] { N }
+ Constant [ public string TagInfinity ] { I }
+ Constant [ public string TagDate ] { D }
+ Constant [ public string TagTime ] { T }
+ Constant [ public string TagUTC ] { Z }
+ Constant [ public string TagBytes ] { b }
+ Constant [ public string TagUTF8Char ] { u }
+ Constant [ public string TagString ] { s }
+ Constant [ public string TagGuid ] { g }
+ Constant [ public string TagList ] { a }
+ Constant [ public string TagMap ] { m }
+ Constant [ public string TagClass ] { c }
+ Constant [ public string TagObject ] { o }
+ Constant [ public string TagRef ] { r }
+ Constant [ public string TagPos ] { + }
+ Constant [ public string TagNeg ] { - }
+ Constant [ public string TagSemicolon ] { ; }
+ Constant [ public string TagOpenbrace ] { { }
+ Constant [ public string TagClosebrace ] { } }
+ Constant [ public string TagQuote ] { " }
+ Constant [ public string TagPoint ] { . }
+ Constant [ public string TagFunctions ] { F }
+ Constant [ public string TagCall ] { C }
+ Constant [ public string TagResult ] { R }
+ Constant [ public string TagArgument ] { A }
+ Constant [ public string TagError ] { E }
+ Constant [ public string TagEnd ] { z }
}
- Static properties [0] {
diff --git a/php-pecl-hprose.spec b/php-pecl-hprose.spec
index 0d292d0..01b8ecc 100644
--- a/php-pecl-hprose.spec
+++ b/php-pecl-hprose.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-hprose
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,14 +22,12 @@
Summary: Hprose for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.6.6
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.6.7
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/hprose/hprose-pecl/pull/14.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -49,14 +47,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -66,9 +56,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -106,8 +100,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr14
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_HPROSE_VERSION/{s/.* "//;s/".*$//;p}' php_hprose.h)
if test "x${extver}" != "x%{version}"; then
@@ -242,6 +234,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jun 5 2019 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7
+- drop patch merged upstream
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.6.6-5
- rebuild for 7.3.0beta2 new ABI