summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-05 17:37:01 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-05 17:37:01 +0100
commitc99d5716af5d86111cdf486ad413cfffe4187cc5 (patch)
tree492414c1359b3a17cb6289e76886c72e3d5a0aca
parent78e9413b32eb3d195ab0e55fc50b1f649650e44b (diff)
php-pecl-hprose: F24
-rw-r--r--php-pecl-hprose.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-hprose.spec b/php-pecl-hprose.spec
index 5fef179..2f7094c 100644
--- a/php-pecl-hprose.spec
+++ b/php-pecl-hprose.spec
@@ -15,9 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-hprose}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name hprose
@@ -31,7 +28,7 @@
Summary: Hprose for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.6.4
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -45,10 +42,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -99,8 +98,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
mv %{pecl_name}-%{version} NTS
-# Don't install tests
+# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
cd NTS
@@ -168,6 +168,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -184,6 +185,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -240,6 +242,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.6.4-2
+- adapt for F24
+
* Wed Jan 06 2016 Remi Collet <remi@fedoraproject.org> - 1.6.4-1
- Update to 1.6.4 (stable)
no change, only our patch merged
@@ -316,4 +321,5 @@ rm -rf %{buildroot}
* Thu Apr 2 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package, version 1.0.0 (stable)
- open https://github.com/hprose/hprose-pecl/issues/1 - php 7
-- open https://github.com/hprose/hprose-pecl/issues/2 - i386 \ No newline at end of file
+- open https://github.com/hprose/hprose-pecl/issues/2 - i386
+