summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-23 08:00:35 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-23 08:00:35 +0200
commit85b5feca7006a568166f91b76cac76cc909b50e5 (patch)
tree4f8b02d5ecc143c705ec31a27d1a0f38f9013709
parentc62cfbadc147773289103ba378c3c7a80d09e303 (diff)
php-pecl-hprose: 1.6.0
-rw-r--r--REFLECTION669
-rw-r--r--php-pecl-hprose.spec7
2 files changed, 7 insertions, 669 deletions
diff --git a/REFLECTION b/REFLECTION
index 824bb03..6b85dbc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 hprose version 1.5.5 ] {
+Extension [ <persistent> extension #99 hprose version 1.6.0 ] {
- Functions {
Function [ <internal:hprose> function hprose_serialize ] {
@@ -22,7 +22,7 @@ Extension [ <persistent> extension #98 hprose version 1.5.5 ] {
}
}
- - Classes [16] {
+ - Classes [7] {
Class [ <internal:hprose> class HproseTags ] {
- Constants [34] {
@@ -772,671 +772,6 @@ Extension [ <persistent> extension #98 hprose version 1.5.5 ] {
- Methods [0] {
}
}
-
- Class [ <internal:hprose> class HproseResultMode ] {
-
- - Constants [4] {
- Constant [ integer Normal ] { 0 }
- Constant [ integer Serialized ] { 1 }
- Constant [ integer Raw ] { 2 }
- Constant [ integer RawWithEndTag ] { 3 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
- Interface [ <internal:hprose> interface HproseFilter ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:hprose> abstract public method inputFilter ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> abstract public method outputFilter ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $data ]
- Parameter #1 [ <required> $context ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> class HproseCompleter ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [4] {
- Method [ <internal:hprose, ctor> public method __construct ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method complete ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $result ]
- }
- }
-
- Method [ <internal:hprose> public method completeError ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Exception $error ]
- }
- }
-
- Method [ <internal:hprose> public method future ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:hprose> class HproseFuture ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:hprose> public method then ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $handler ]
- }
- }
-
- Method [ <internal:hprose> public method catchError ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $errorHandler ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> class HproseProxy ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [3] {
- Method [ <internal:hprose, ctor> public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> HproseClient $client ]
- Parameter #1 [ <optional> $ns ]
- }
- }
-
- Method [ <internal:hprose> public method __call ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> array $args ]
- }
- }
-
- Method [ <internal:hprose> public method __get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> abstract class HproseClient extends HproseProxy ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [1] {
- Property [ <default> protected $url ]
- }
-
- - Methods [14] {
- Method [ <internal:hprose, overwrites HproseProxy, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $url ]
- }
- }
-
- Method [ <internal:hprose> protected method sendAndReceive ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $request ]
- }
- }
-
- Method [ <internal:hprose> protected method asyncSendAndReceive ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $request ]
- Parameter #1 [ <required> $use ]
- }
- }
-
- Method [ <internal:hprose> protected method sendAndReceiveCallback ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $response ]
- Parameter #1 [ <required> Exception or NULL $err ]
- Parameter #2 [ <required> array $use ]
- }
- }
-
- Method [ <internal:hprose> public method useService ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $url ]
- Parameter #1 [ <optional> $ns ]
- }
- }
-
- Method [ <internal:hprose> public method invoke ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <optional> array &$args ]
- Parameter #2 [ <optional> $byref ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- Parameter #5 [ <optional> $callback ]
- }
- }
-
- Method [ <internal:hprose> public method getFilter ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter or NULL $filter ]
- }
- }
-
- Method [ <internal:hprose> public method addFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter $filter ]
- }
- }
-
- Method [ <internal:hprose> public method removeFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter $filter ]
- }
- }
-
- Method [ <internal:hprose> public method getSimple ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setSimple ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose, inherits HproseProxy> public method __call ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> array $args ]
- }
- }
-
- Method [ <internal:hprose, inherits HproseProxy> public method __get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> abstract class HproseService ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [1] {
- Method [ <internal:hprose> static public method getErrorTypeString ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $errno ]
- }
- }
- }
-
- - Properties [5] {
- Property [ <default> protected $debug ]
- Property [ <default> protected $error_types ]
- Property [ <default> public $onBeforeInvoke ]
- Property [ <default> public $onAfterInvoke ]
- Property [ <default> public $onSendError ]
- }
-
- - Methods [30] {
- Method [ <internal:hprose> public method sendError ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $error ]
- Parameter #1 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> protected method doInvoke ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> HproseBytesIO $input ]
- Parameter #1 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> protected method doFunctionList ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> public method isDebugEnabled ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setDebugEnabled ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $enable ]
- }
- }
-
- Method [ <internal:hprose> public method getErrorTypes ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setErrorTypes ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $error_types ]
- }
- }
-
- Method [ <internal:hprose> public method getFilter ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter or NULL $filter ]
- }
- }
-
- Method [ <internal:hprose> public method addFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter $filter ]
- }
- }
-
- Method [ <internal:hprose> public method removeFilter ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseFilter $filter ]
- }
- }
-
- Method [ <internal:hprose> public method getSimple ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:hprose> public method setSimple ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method defaultHandle ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $request ]
- Parameter #1 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> public method addMissingFunction ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $func ]
- Parameter #1 [ <optional> $mode ]
- Parameter #2 [ <optional> $simple ]
- Parameter #3 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addFunction ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $func ]
- Parameter #1 [ <optional> $alias ]
- Parameter #2 [ <optional> $mode ]
- Parameter #3 [ <optional> $simple ]
- Parameter #4 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addFunctions ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> array $funcs ]
- Parameter #1 [ <optional> array or NULL $aliases ]
- Parameter #2 [ <optional> $mode ]
- Parameter #3 [ <optional> $simple ]
- Parameter #4 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addMethod ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> $methodname ]
- Parameter #1 [ <required> $belongto ]
- Parameter #2 [ <optional> $alias ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- Parameter #5 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addMethods ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> array $methods ]
- Parameter #1 [ <required> $belongto ]
- Parameter #2 [ <optional> $aliases ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- Parameter #5 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addInstanceMethods ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> $obj ]
- Parameter #1 [ <optional> $class_name ]
- Parameter #2 [ <optional> $alias_prefix ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- Parameter #5 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method addClassMethods ] {
-
- - Parameters [6] {
- Parameter #0 [ <required> $class_name ]
- Parameter #1 [ <optional> $exec_class ]
- Parameter #2 [ <optional> $alias_prefix ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- Parameter #5 [ <optional> $async ]
- }
- }
-
- Method [ <internal:hprose> public method add ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $arg1 ]
- Parameter #1 [ <optional> $arg2 ]
- Parameter #2 [ <optional> $arg3 ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncMissingFunction ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $func ]
- Parameter #1 [ <optional> $mode ]
- Parameter #2 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncFunction ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $func ]
- Parameter #1 [ <optional> $alias ]
- Parameter #2 [ <optional> $mode ]
- Parameter #3 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncFunctions ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> array $funcs ]
- Parameter #1 [ <optional> array or NULL $aliases ]
- Parameter #2 [ <optional> $mode ]
- Parameter #3 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncMethod ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $methodname ]
- Parameter #1 [ <required> $belongto ]
- Parameter #2 [ <optional> $alias ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncMethods ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> array $methods ]
- Parameter #1 [ <required> $belongto ]
- Parameter #2 [ <optional> $aliases ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncInstanceMethods ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $obj ]
- Parameter #1 [ <optional> $class_name ]
- Parameter #2 [ <optional> $alias_prefix ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsyncClassMethods ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> $class_name ]
- Parameter #1 [ <optional> $exec_class ]
- Parameter #2 [ <optional> $alias_prefix ]
- Parameter #3 [ <optional> $mode ]
- Parameter #4 [ <optional> $simple ]
- }
- }
-
- Method [ <internal:hprose> public method addAsync ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $arg1 ]
- Parameter #1 [ <optional> $arg2 ]
- Parameter #2 [ <optional> $arg3 ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> class HproseAsyncCallback ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:hprose, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> HproseCompleter $completer ]
- }
- }
-
- Method [ <internal:hprose> public method handler ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $result ]
- }
- }
- }
- }
-
- Class [ <internal:hprose> class HproseAfterInvokeCallback ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [3] {
- Method [ <internal:hprose, ctor> public method __construct ] {
-
- - Parameters [8] {
- Parameter #0 [ <required> HproseService $service ]
- Parameter #1 [ <required> HproseCompleter $completer ]
- Parameter #2 [ <required> $name ]
- Parameter #3 [ <required> array $args ]
- Parameter #4 [ <required> $byref ]
- Parameter #5 [ <required> $mode ]
- Parameter #6 [ <required> $simple ]
- Parameter #7 [ <required> $context ]
- }
- }
-
- Method [ <internal:hprose> public method handler ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $result ]
- }
- }
-
- Method [ <internal:hprose> public method errorHandler ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> Exception $error ]
- }
- }
- }
- }
}
}
diff --git a/php-pecl-hprose.spec b/php-pecl-hprose.spec
index 1c49435..c685e60 100644
--- a/php-pecl-hprose.spec
+++ b/php-pecl-hprose.spec
@@ -30,8 +30,8 @@
Summary: Hprose for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.5.5
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.6.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -247,6 +247,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Aug 23 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
+- Update to 1.6.0
+
* Wed Jul 22 2015 Remi Collet <remi@fedoraproject.org> - 1.5.5-3
- rebuild against php 7.0.0beta2