summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-11 09:17:52 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-11 09:17:52 +0200
commit630244a4f6180e953a08703ea1c3ee0909c21b57 (patch)
tree39f0891ade4b7ac2b1cd8ce776ffee3e0ed526ce
parent5f5c3e25c3d86af212a8c72528faa650abaeaa9b (diff)
php-pecl-hprose: 1.5.2
-rw-r--r--REFLECTION259
-rw-r--r--php-pecl-hprose.spec11
2 files changed, 257 insertions, 13 deletions
diff --git a/REFLECTION b/REFLECTION
index 2846126..c44214d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
+Extension [ <persistent> extension #98 hprose version 1.5.2 ] {
- Functions {
Function [ <internal:hprose> function hprose_serialize ] {
@@ -22,7 +22,7 @@ Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
}
}
- - Classes [12] {
+ - Classes [16] {
Class [ <internal:hprose> class HproseTags ] {
- Constants [34] {
@@ -828,6 +828,80 @@ Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
}
}
+ Class [ <internal:hprose> class HproseCompleter ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:hprose, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:hprose> public method complete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $result ]
+ }
+ }
+
+ Method [ <internal:hprose> public method completeError ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Exception $error ]
+ }
+ }
+
+ Method [ <internal:hprose> public method future ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:hprose> class HproseFuture ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:hprose> public method then ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $handler ]
+ }
+ }
+
+ Method [ <internal:hprose> public method catchError ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $errorHandler ]
+ }
+ }
+ }
+ }
+
Class [ <internal:hprose> class HproseProxy ] {
- Constants [0] {
@@ -1017,7 +1091,7 @@ Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
Property [ <default> public $onSendError ]
}
- - Methods [22] {
+ - Methods [30] {
Method [ <internal:hprose> public method sendError ] {
- Parameters [2] {
@@ -1117,74 +1191,81 @@ Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
Method [ <internal:hprose> public method addMissingFunction ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $func ]
Parameter #1 [ <optional> $mode ]
Parameter #2 [ <optional> $simple ]
+ Parameter #3 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addFunction ] {
- - Parameters [4] {
+ - Parameters [5] {
Parameter #0 [ <required> $func ]
Parameter #1 [ <optional> $alias ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $simple ]
+ Parameter #4 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addFunctions ] {
- - Parameters [4] {
+ - Parameters [5] {
Parameter #0 [ <required> array $funcs ]
Parameter #1 [ <optional> array or NULL $aliases ]
Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $simple ]
+ Parameter #4 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addMethod ] {
- - Parameters [5] {
+ - Parameters [6] {
Parameter #0 [ <required> $methodname ]
Parameter #1 [ <required> $belongto ]
Parameter #2 [ <optional> $alias ]
Parameter #3 [ <optional> $mode ]
Parameter #4 [ <optional> $simple ]
+ Parameter #5 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addMethods ] {
- - Parameters [5] {
+ - Parameters [6] {
Parameter #0 [ <required> array $methods ]
Parameter #1 [ <required> $belongto ]
Parameter #2 [ <optional> $aliases ]
Parameter #3 [ <optional> $mode ]
Parameter #4 [ <optional> $simple ]
+ Parameter #5 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addInstanceMethods ] {
- - Parameters [5] {
+ - Parameters [6] {
Parameter #0 [ <required> $obj ]
Parameter #1 [ <optional> $class_name ]
Parameter #2 [ <optional> $alias_prefix ]
Parameter #3 [ <optional> $mode ]
Parameter #4 [ <optional> $simple ]
+ Parameter #5 [ <optional> $async ]
}
}
Method [ <internal:hprose> public method addClassMethods ] {
- - Parameters [5] {
+ - Parameters [6] {
Parameter #0 [ <required> $class_name ]
Parameter #1 [ <optional> $exec_class ]
Parameter #2 [ <optional> $alias_prefix ]
Parameter #3 [ <optional> $mode ]
Parameter #4 [ <optional> $simple ]
+ Parameter #5 [ <optional> $async ]
}
}
@@ -1196,6 +1277,164 @@ Extension [ <persistent> extension #98 hprose version 1.4.2 ] {
Parameter #2 [ <optional> $arg3 ]
}
}
+
+ Method [ <internal:hprose> public method addAsyncMissingFunction ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $func ]
+ Parameter #1 [ <optional> $mode ]
+ Parameter #2 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncFunction ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $func ]
+ Parameter #1 [ <optional> $alias ]
+ Parameter #2 [ <optional> $mode ]
+ Parameter #3 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncFunctions ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> array $funcs ]
+ Parameter #1 [ <optional> array or NULL $aliases ]
+ Parameter #2 [ <optional> $mode ]
+ Parameter #3 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncMethod ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $methodname ]
+ Parameter #1 [ <required> $belongto ]
+ Parameter #2 [ <optional> $alias ]
+ Parameter #3 [ <optional> $mode ]
+ Parameter #4 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncMethods ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> array $methods ]
+ Parameter #1 [ <required> $belongto ]
+ Parameter #2 [ <optional> $aliases ]
+ Parameter #3 [ <optional> $mode ]
+ Parameter #4 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncInstanceMethods ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $obj ]
+ Parameter #1 [ <optional> $class_name ]
+ Parameter #2 [ <optional> $alias_prefix ]
+ Parameter #3 [ <optional> $mode ]
+ Parameter #4 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsyncClassMethods ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $class_name ]
+ Parameter #1 [ <optional> $exec_class ]
+ Parameter #2 [ <optional> $alias_prefix ]
+ Parameter #3 [ <optional> $mode ]
+ Parameter #4 [ <optional> $simple ]
+ }
+ }
+
+ Method [ <internal:hprose> public method addAsync ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $arg1 ]
+ Parameter #1 [ <optional> $arg2 ]
+ Parameter #2 [ <optional> $arg3 ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:hprose> class HproseAsyncCallback ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:hprose, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> HproseCompleter $completer ]
+ }
+ }
+
+ Method [ <internal:hprose> public method handler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $result ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:hprose> class HproseAfterInvokeCallback ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:hprose, ctor> public method __construct ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> HproseService $service ]
+ Parameter #1 [ <required> HproseCompleter $completer ]
+ Parameter #2 [ <required> $name ]
+ Parameter #3 [ <required> array $args ]
+ Parameter #4 [ <required> $byref ]
+ Parameter #5 [ <required> $mode ]
+ Parameter #6 [ <required> $simple ]
+ Parameter #7 [ <required> $context ]
+ }
+ }
+
+ Method [ <internal:hprose> public method handler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $result ]
+ }
+ }
+
+ Method [ <internal:hprose> public method errorHandler ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Exception $error ]
+ }
+ }
}
}
}
diff --git a/php-pecl-hprose.spec b/php-pecl-hprose.spec
index a5c340c..2c77535 100644
--- a/php-pecl-hprose.spec
+++ b/php-pecl-hprose.spec
@@ -22,7 +22,7 @@
Summary: Hprose for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.4.2
+Version: 1.5.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
@@ -84,6 +84,8 @@ languages.
This project is the implementation of Hprose for PHP.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
%prep
%setup -q -c
@@ -223,10 +225,10 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE.md}
-
+%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -237,6 +239,9 @@ rm -rf %{buildroot}
%changelog
+* Mon May 11 2015 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
+- Update to 1.5.2
+
* Mon Apr 20 2015 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
- Update to 1.4.2