summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-07 16:52:32 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-07 16:52:32 +0200
commit3da9951e9a4d000af6d441ed9800d39cec7e8ea9 (patch)
tree7fbb02e95e48facc46a3fa2384bd3894fcd0d5da
parent9f7b977c683473beae4f0b10537bc6a646541e2f (diff)
php-pecl-hprose: 1.2.0
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-hprose.spec16
2 files changed, 42 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index a49cd19..d6163e2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 hprose version 1.1.0 ] {
+Extension [ <persistent> extension #98 hprose version 1.2.0 ] {
- Functions {
Function [ <internal:hprose> function hprose_serialize ] {
@@ -89,7 +89,7 @@ Extension [ <persistent> extension #98 hprose version 1.1.0 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [19] {
Method [ <internal:hprose, ctor> public method __construct ] {
- Parameters [1] {
@@ -187,6 +187,20 @@ Extension [ <persistent> extension #98 hprose version 1.1.0 ] {
}
}
+ Method [ <internal:hprose> public method load ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $filename ]
+ }
+ }
+
+ Method [ <internal:hprose> public method save ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $filename ]
+ }
+ }
+
Method [ <internal:hprose> public method toString ] {
- Parameters [0] {
@@ -254,7 +268,7 @@ Extension [ <persistent> extension #98 hprose version 1.1.0 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [31] {
Method [ <internal:hprose, ctor> public method __construct ] {
- Parameters [2] {
@@ -364,6 +378,20 @@ Extension [ <persistent> extension #98 hprose version 1.1.0 ] {
}
}
+ Method [ <internal:hprose> public method writeBytesIO ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> HproseBytesIO $dt ]
+ }
+ }
+
+ Method [ <internal:hprose> public method writeBytesIOWithRef ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> HproseBytesIO $dt ]
+ }
+ }
+
Method [ <internal:hprose> public method writeDateTime ] {
- Parameters [1] {
diff --git a/php-pecl-hprose.spec b/php-pecl-hprose.spec
index b4fb47e..5885b47 100644
--- a/php-pecl-hprose.spec
+++ b/php-pecl-hprose.spec
@@ -22,7 +22,7 @@
Summary: Hprose for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.0
+Version: 1.2.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
@@ -56,6 +56,10 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -174,11 +178,10 @@ fi
%check
%if "%{php_version}" > "7"
# These tests strangly fail "only" in mock
-%if 0%{rhel} < 7 && 0%{?fedora} < 20
-[ "$(id -nu)" == "remi" ] || rm ?TS/tests/{class_manager,formatter,raw_reader,writer}.phpt
-%else
-[ "$(id -nu)" == "remi" ] || rm ?TS/tests/formatter.phpt
+%if 0%{?rhel} < 7 && 0%{?fedora} < 20
+[ "$(id -nu)" == "remi" ] || rm ?TS/tests/{class_manager,raw_reader,reader}.phpt
%endif
+[ "$(id -nu)" == "remi" ] || rm ?TS/tests/formatter.phpt
%endif
cd NTS
@@ -234,6 +237,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Apr 07 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- Update to 1.2.0
+
* Fri Apr 3 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
- Update to 1.1.0