summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 09:58:41 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 09:58:41 +0200
commit5c95f1fe6363fcfaf2fa7ad273ac7e930136fcf0 (patch)
tree83cb080c67a3c40009eed99cf5c460a55f47d585
parent054ead32e2b1fcbc6a95d4d0b7c3ad3069f08ac0 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-hidef.spec28
1 files changed, 18 insertions, 10 deletions
diff --git a/php-pecl-hidef.spec b/php-pecl-hidef.spec
index b86b26c..5fcf157 100644
--- a/php-pecl-hidef.spec
+++ b/php-pecl-hidef.spec
@@ -11,13 +11,18 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
-%global pecl_name hidef
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name hidef
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Constants for real
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.13
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -92,7 +97,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
@@ -132,8 +137,8 @@ make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
install -d -m 755 %{buildroot}%{php_inidir}/%{pecl_name}
-sed -e 's:@INIDIR@:%{php_inidir}:' %{pecl_name}.ini \
- >%{buildroot}%{php_inidir}/%{pecl_name}.ini
+sed -e 's:@INIDIR@:%{php_inidir}:' %{ini_name} \
+ >%{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
@@ -143,8 +148,8 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS install INSTALL_ROOT=%{buildroot}
install -d -m 755 %{buildroot}%{php_ztsinidir}/%{pecl_name}
-sed -e 's:@INIDIR@:%{php_ztsinidir}:' %{pecl_name}.ini \
- >%{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+sed -e 's:@INIDIR@:%{php_ztsinidir}:' %{ini_name} \
+ >%{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -214,17 +219,20 @@ rm -rf %{buildroot}
%{pecl_xmldir}/%{name}.xml
%dir %{php_inidir}/%{pecl_name}
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
%dir %{php_ztsinidir}/%{pecl_name}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 0.1.13-4
+- add numerical prefix to extension configuration file
+
* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 0.1.13-3
- allow SCL build