summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-05 17:33:57 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-05 17:33:57 +0100
commitdf836f007d0f0393162746da61a1e15a937eb9ee (patch)
treebc00ba65cc623d35bc40d4d80ce419d7cb549281
parent4e678e0877a95b629aa09a10c2a857d530e52b12 (diff)
php-pecl-hdr-histogram: F24
-rw-r--r--php-pecl-hdr-histogram.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/php-pecl-hdr-histogram.spec b/php-pecl-hdr-histogram.spec
index e21e60f..93fae04 100644
--- a/php-pecl-hdr-histogram.spec
+++ b/php-pecl-hdr-histogram.spec
@@ -15,9 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-hdr-histogram}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name hdr_histogram
@@ -31,7 +28,7 @@
Summary: PHP extension wrapper for the C hdrhistogram API
Name: %{?sub_prefix}php-pecl-hdr-histogram
Version: 0.1.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -47,10 +44,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -95,7 +94,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Remove test file to avoid regsitration
-sed -e '/role="test"/d' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
# Check upstream version (often broken)
@@ -192,6 +193,7 @@ REPORT_EXIT_STATUS=1 \
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -208,6 +210,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -226,9 +229,13 @@ fi
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 0.1.0-2
+- adapt for F24
+
* Fri Jan 1 2016 Remi Collet <remi@fedoraproject.org> - 0.1.0-1
- initial RPM, version 0.1.0 (beta)
- fix test suite on i386
open https://github.com/beberlei/hdrhistogram-php/pull/10
- honours --with-libdir option
- open https://github.com/beberlei/hdrhistogram-php/pull/9 \ No newline at end of file
+ open https://github.com/beberlei/hdrhistogram-php/pull/9
+