summaryrefslogtreecommitdiffstats
path: root/php-pecl-handlebars.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-handlebars.spec')
-rw-r--r--php-pecl-handlebars.spec44
1 files changed, 22 insertions, 22 deletions
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 29cfaa8..4fe11c2 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-handlebars
#
-# Copyright (c) 2017-2018 Remi Collet
+# Copyright (c) 2017-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,27 +13,25 @@
%global pecl_name handlebars
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
# After 40-psr.ini
%global ini_name 50-%{pecl_name}.ini
-%endif
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 0.8.3
+%global upstream_version 0.9.0
#global upstream_prever RC2
Summary: Handlebars templating language
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+
+Patch0: 0001-fix-test-for-php-7-8.patch
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 5.6
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libhandlebars-devel
BuildRequires: libtalloc-devel
@@ -56,20 +54,8 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
@@ -117,6 +103,8 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/PHP_HANDLEBARS_VERSION/{s/.* "//;s/".*$//;p}' php_handlebars.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -221,6 +209,10 @@ fi
%check
+%if %{__isa_bits} < 64
+rm ?TS/tests/vm/renderFromBinaryString.phpt
+%endif
+
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
@@ -279,6 +271,14 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Apr 17 2020 Remi Collet <remi@remirepo.net> - 0.9.0-1
+- update to 0.9.0
+- raise dependency on PHP 7.2
+- fix test suite with PHP 8 using patch from
+ https://github.com/jbboehr/php-handlebars/pull/66
+- skip 1 test on 32-bit reported as
+ https://github.com/jbboehr/php-handlebars/issues/67
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.8.3-2
- rebuild for 7.4.0RC1