summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-09 16:23:07 +0200
committerRemi Collet <remi@remirepo.net>2017-06-09 16:23:07 +0200
commit1eb3f28c1513622102518049d0adf055215ab999 (patch)
tree47fe9c73c0d5c056e274e3bdf14ca2e3bae1b41a
parent27fb19ad29ae76398bd22c5a4a3ea4cc36449bfd (diff)
New package
-rw-r--r--REFLECTION1172
-rw-r--r--php-pecl-handlebars.spec52
2 files changed, 1213 insertions, 11 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..72675b2
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,1172 @@
+Extension [ <persistent> extension #93 handlebars version 0.8.2RC1 ] {
+
+ - Dependencies {
+ Dependency [ psr (Optional) ]
+ }
+
+ - INI {
+ Entry [ handlebars.pool_size <ALL> ]
+ Current = '128k'
+ }
+ Entry [ handlebars.cache.enable <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ handlebars.cache.enable_cli <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ handlebars.cache.backend <SYSTEM> ]
+ Current = 'mmap'
+ }
+ Entry [ handlebars.cache.max_size <SYSTEM> ]
+ Current = '67108864'
+ }
+ Entry [ handlebars.cache.max_entries <SYSTEM> ]
+ Current = '349529'
+ }
+ Entry [ handlebars.cache.max_age <SYSTEM> ]
+ Current = '-1'
+ }
+ Entry [ handlebars.cache.save_path <SYSTEM> ]
+ Current = '/tmp/php-handlebars-cache'
+ }
+ Entry [ handlebars.cache.stat <SYSTEM> ]
+ Current = '1'
+ }
+ }
+
+ - Constants [4] {
+ Constant [ integer Handlebars\PSR ] { 0 }
+ Constant [ string Handlebars\VERSION ] { 0.8.2RC1 }
+ Constant [ string Handlebars\LIBVERSION ] { 0.6.3 }
+ Constant [ null Handlebars\CACHE_BACKEND ] { }
+ }
+
+ - Functions {
+ Function [ <internal:handlebars> function handlebars_cache_reset ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Classes [19] {
+ Interface [ <internal:handlebars> interface Handlebars\Impl ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:handlebars> abstract public method getHelpers ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method getPartials ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method getDecorators ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method getLogger ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method setHelpers ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $helpers ]
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method setPartials ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method setDecorators ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method setLogger ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method render ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $tmpl ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:handlebars> abstract public method renderFile ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> abstract class Handlebars\BaseImpl implements Handlebars\Impl ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $helpers ]
+ Property [ <default> protected $partials ]
+ Property [ <default> protected $decorators ]
+ Property [ <default> protected $logger ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method getHelpers ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method getPartials ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method getDecorators ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method getLogger ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method setHelpers ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $helpers ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method setPartials ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method setDecorators ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method setLogger ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\Impl> abstract public method render ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $tmpl ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\Impl> abstract public method renderFile ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Compiler ] {
+
+ - Constants [18] {
+ Constant [ integer NONE ] { 0 }
+ Constant [ integer USE_DEPTHS ] { 1 }
+ Constant [ integer STRING_PARAMS ] { 2 }
+ Constant [ integer TRACK_IDS ] { 4 }
+ Constant [ integer NO_ESCAPE ] { 8 }
+ Constant [ integer KNOWN_HELPERS_ONLY ] { 16 }
+ Constant [ integer PREVENT_INDENT ] { 32 }
+ Constant [ integer EXPLICIT_PARTIAL_CONTEXT ] { 128 }
+ Constant [ integer IGNORE_STANDALONE ] { 256 }
+ Constant [ integer ALTERNATE_DECORATORS ] { 512 }
+ Constant [ integer STRICT ] { 1024 }
+ Constant [ integer ASSUME_OBJECTS ] { 2048 }
+ Constant [ integer COMPAT ] { 1 }
+ Constant [ integer ALL ] { 4095 }
+ Constant [ integer USE_PARTIAL ] { 2 }
+ Constant [ integer IS_SIMPLE ] { 4 }
+ Constant [ integer USE_DECORATORS ] { 8 }
+ Constant [ integer RESULT_ALL ] { 15 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method compile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tmpl ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method compilePrint ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tmpl ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:handlebars> interface Handlebars\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\ParseException extends Exception implements Throwable, Handlebars\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\CompileException extends Exception implements Throwable, Handlebars\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\InvalidArgumentException extends RuntimeException implements Throwable, Handlebars\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\RuntimeException extends RuntimeException implements Throwable, Handlebars\Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Opcode ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $opcode ]
+ Property [ <default> public $args ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $opcode ]
+ Parameter #1 [ <required> $args ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Options implements ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [8] {
+ Property [ <default> public $ids ]
+ Property [ <default> public $hashIds ]
+ Property [ <default> public $hashTypes ]
+ Property [ <default> public $hashContexts ]
+ Property [ <default> public $types ]
+ Property [ <default> public $contexts ]
+ Property [ <default> public $args ]
+ Property [ <default> public $partial ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array or NULL $props ]
+ }
+ }
+
+ Method [ <internal:handlebars> public method fn ] {
+ }
+
+ Method [ <internal:handlebars> public method inverse ] {
+ }
+
+ Method [ <internal:handlebars, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $prop ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $prop ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $prop ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:handlebars, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $prop ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Parser ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method parse ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $tmpl ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method parsePrint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $tmpl ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Program ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [10] {
+ Property [ <default> public $opcodes ]
+ Property [ <default> public $children ]
+ Property [ <default> public $decorators ]
+ Property [ <default> public $isSimple ]
+ Property [ <default> public $useDepths ]
+ Property [ <default> public $usePartial ]
+ Property [ <default> public $useDecorators ]
+ Property [ <default> public $blockParams ]
+ Property [ <default> public $stringParams ]
+ Property [ <default> public $trackIds ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> array $opcodes ]
+ Parameter #1 [ <required> array $children ]
+ Parameter #2 [ <optional> $blockParams ]
+ }
+ }
+ }
+ }
+
+ Interface [ <internal:handlebars> interface Handlebars\Registry extends ArrayAccess, Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> <iterateable> class Handlebars\DefaultRegistry extends ArrayObject implements Countable, Serializable, ArrayAccess, Traversable, IteratorAggregate, Handlebars\Registry ] {
+
+ - Constants [2] {
+ Constant [ integer STD_PROP_LIST ] { 1 }
+ Constant [ integer ARRAY_AS_PROPS ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [22] {
+ Method [ <internal:SPL, inherits ArrayObject, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $array ]
+ Parameter #1 [ <optional> $ar_flags ]
+ Parameter #2 [ <optional> $iterator_class ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $newval ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method append ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method getArrayCopy ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method getFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method setFlags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $flags ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method asort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method ksort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method uasort ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cmp_function ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method uksort ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cmp_function ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method natsort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method natcasesort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject, prototype IteratorAggregate> public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method exchangeArray ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $array ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method setIteratorClass ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $iteratorClass ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method getIteratorClass ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\SafeString ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $value ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:handlebars> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Token ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $name ]
+ Property [ <default> public $text ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $text ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Tokenizer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method lex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $tmpl ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method lexPrint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $tmpl ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Utils ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [9] {
+ Method [ <internal:handlebars> static public method appendContextPath ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $contextPath ]
+ Parameter #1 [ <required> $id ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method createFrame ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method nameLookup ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $objOrArray ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method indent ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $str ]
+ Parameter #1 [ <required> $indent ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method isCallable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method isIntArray ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $arr ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method expression ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method escapeExpression ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:handlebars> static public method escapeExpressionCompat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\VM extends Handlebars\BaseImpl implements Handlebars\Impl ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $helpers ]
+ Property [ <default> protected $partials ]
+ Property [ <default> protected $decorators ]
+ Property [ <default> protected $logger ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:handlebars, overwrites Handlebars\BaseImpl, prototype Handlebars\Impl> public method setHelpers ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $helpers ]
+ }
+ }
+
+ Method [ <internal:handlebars, overwrites Handlebars\BaseImpl, prototype Handlebars\Impl> public method setPartials ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars, overwrites Handlebars\Impl, prototype Handlebars\Impl> public method render ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $tmpl ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:handlebars, overwrites Handlebars\Impl, prototype Handlebars\Impl> public method renderFile ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <optional> $context ]
+ Parameter #2 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getHelpers ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getPartials ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getDecorators ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getLogger ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method setDecorators ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Handlebars\Registry $partials ]
+ }
+ }
+
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method setLogger ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 38e3573..792830c 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -11,9 +11,10 @@
%scl_package php-pecl-handlebars
%endif
-%global pecl_name handlebars
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
+%global pecl_name handlebars
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global with_tests 0%{!?_without_tests:1}
%global upstream_version 0.8.2
%global upstream_prever RC1
@@ -29,7 +30,8 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstr
BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: handlebars-devel
+BuildRequires: libhandlebars-devel
+BuildRequires: libtalloc-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -94,10 +96,9 @@ These are the files needed to compile programs using %{name}.
%setup -q -c
mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
+# Don't install/register License
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
@@ -118,6 +119,17 @@ cp -pr NTS ZTS
cat << 'EOF' | tee %{ini_name}
; Enable "%{pecl_name}" extension module
extension=%{pecl_name}.so
+
+; Configuration
+;handlebars.pool_size = '128k'
+;handlebars.cache.enable = 1
+;handlebars.cache.enable_cli = 0
+;handlebars.cache.backend = 'mmap'
+;handlebars.cache.max_size = 67108864
+;handlebars.cache.max_entries = 349529
+;handlebars.cache.max_age = -1
+;handlebars.cache.save_path = '/tmp/php-handlebars-cache'
+;handlebars.cache.stat = 1
EOF
@@ -166,8 +178,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Test & Documentation
for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do [ -f NTS/tests/$i ] && install -Dpm 644 NTS/tests/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/tests/$i
- [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
done
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
@@ -201,18 +212,37 @@ cd NTS
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with_tests}
+# Upstream test suite
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
%if %{with_zts}
: Minimal load test for ZTS extension
cd ../ZTS
%{__ztsphp} --no-php-ini \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
+
+%if %{with_tests}
+# Upstream test suite
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
%endif
%files
%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
+%license NTS/LICENSE.md
+%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}