summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-06 06:15:56 +0100
committerRemi Collet <remi@remirepo.net>2018-03-06 06:15:56 +0100
commit1bd7ea84e6c08728e32d31bc28f5cffed1b4f18c (patch)
tree929a41d927f72576a3fa8cad1dea56ab7116f178
parent077223a4277e5ee68253cfc98c25f416b6997a1b (diff)
update to 0.8.2 (stable)
add optional dependency on psr extension
-rw-r--r--REFLECTION54
-rw-r--r--php-pecl-handlebars.spec17
2 files changed, 39 insertions, 32 deletions
diff --git a/REFLECTION b/REFLECTION
index 6c9086a..4b5bb87 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
+Extension [ <persistent> extension #181 handlebars version 0.8.2 ] {
- Dependencies {
Dependency [ psr (Optional) ]
@@ -35,8 +35,8 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
}
- Constants [4] {
- Constant [ integer Handlebars\PSR ] { 0 }
- Constant [ string Handlebars\VERSION ] { 0.8.2RC2 }
+ Constant [ integer Handlebars\PSR ] { 1 }
+ Constant [ string Handlebars\VERSION ] { 0.8.2 }
Constant [ string Handlebars\LIBVERSION ] { 0.6.4 }
Constant [ null Handlebars\CACHE_BACKEND ] { }
}
@@ -50,7 +50,7 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
}
- Classes [19] {
- Interface [ <internal:handlebars> interface Handlebars\Impl ] {
+ Interface [ <internal:handlebars> interface Handlebars\Impl extends Psr\Log\LoggerAwareInterface ] {
- Constants [0] {
}
@@ -110,7 +110,7 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
}
}
- Method [ <internal:handlebars> abstract public method setLogger ] {
+ Method [ <internal:handlebars, prototype Psr\Log\LoggerAwareInterface> abstract public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
@@ -137,7 +137,7 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
}
}
- Class [ <internal:handlebars> abstract class Handlebars\BaseImpl implements Handlebars\Impl ] {
+ Class [ <internal:handlebars> abstract class Handlebars\BaseImpl implements Handlebars\Impl, Psr\Log\LoggerAwareInterface ] {
- Constants [0] {
}
@@ -231,24 +231,24 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
Class [ <internal:handlebars> class Handlebars\Compiler ] {
- Constants [18] {
- Constant [ integer NONE ] { 0 }
- Constant [ integer USE_DEPTHS ] { 1 }
- Constant [ integer STRING_PARAMS ] { 2 }
- Constant [ integer TRACK_IDS ] { 4 }
- Constant [ integer NO_ESCAPE ] { 8 }
- Constant [ integer KNOWN_HELPERS_ONLY ] { 16 }
- Constant [ integer PREVENT_INDENT ] { 32 }
- Constant [ integer EXPLICIT_PARTIAL_CONTEXT ] { 128 }
- Constant [ integer IGNORE_STANDALONE ] { 256 }
- Constant [ integer ALTERNATE_DECORATORS ] { 512 }
- Constant [ integer STRICT ] { 1024 }
- Constant [ integer ASSUME_OBJECTS ] { 2048 }
- Constant [ integer COMPAT ] { 1 }
- Constant [ integer ALL ] { 4095 }
- Constant [ integer USE_PARTIAL ] { 2 }
- Constant [ integer IS_SIMPLE ] { 4 }
- Constant [ integer USE_DECORATORS ] { 8 }
- Constant [ integer RESULT_ALL ] { 15 }
+ Constant [ public integer NONE ] { 0 }
+ Constant [ public integer USE_DEPTHS ] { 1 }
+ Constant [ public integer STRING_PARAMS ] { 2 }
+ Constant [ public integer TRACK_IDS ] { 4 }
+ Constant [ public integer NO_ESCAPE ] { 8 }
+ Constant [ public integer KNOWN_HELPERS_ONLY ] { 16 }
+ Constant [ public integer PREVENT_INDENT ] { 32 }
+ Constant [ public integer EXPLICIT_PARTIAL_CONTEXT ] { 128 }
+ Constant [ public integer IGNORE_STANDALONE ] { 256 }
+ Constant [ public integer ALTERNATE_DECORATORS ] { 512 }
+ Constant [ public integer STRICT ] { 1024 }
+ Constant [ public integer ASSUME_OBJECTS ] { 2048 }
+ Constant [ public integer COMPAT ] { 1 }
+ Constant [ public integer ALL ] { 4095 }
+ Constant [ public integer USE_PARTIAL ] { 2 }
+ Constant [ public integer IS_SIMPLE ] { 4 }
+ Constant [ public integer USE_DECORATORS ] { 8 }
+ Constant [ public integer RESULT_ALL ] { 15 }
}
- Static properties [0] {
@@ -735,8 +735,8 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
Class [ <internal:handlebars> <iterateable> class Handlebars\DefaultRegistry extends ArrayObject implements Countable, Serializable, ArrayAccess, Traversable, IteratorAggregate, Handlebars\Registry ] {
- Constants [2] {
- Constant [ integer STD_PROP_LIST ] { 1 }
- Constant [ integer ARRAY_AS_PROPS ] { 2 }
+ Constant [ public integer STD_PROP_LIST ] { 1 }
+ Constant [ public integer ARRAY_AS_PROPS ] { 2 }
}
- Static properties [0] {
@@ -1070,7 +1070,7 @@ Extension [ <persistent> extension #92 handlebars version 0.8.2RC2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\VM extends Handlebars\BaseImpl implements Handlebars\Impl ] {
+ Class [ <internal:handlebars> class Handlebars\VM extends Handlebars\BaseImpl implements Psr\Log\LoggerAwareInterface, Handlebars\Impl ] {
- Constants [0] {
}
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 2518a5d..69b43aa 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-handlebars
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,19 +16,19 @@
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
-%global ini_name 40-%{pecl_name}.ini
+# After 40-psr.ini
+%global ini_name 50-%{pecl_name}.ini
%endif
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 0.8.2
-%global upstream_prever RC2
+#global upstream_prever RC2
Summary: Handlebars templating language
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -41,6 +41,9 @@ BuildRequires: libtalloc-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
+Recommends: %{?scl_prefix}php-psr
+%endif
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -190,7 +193,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -269,6 +272,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Mar 6 2018 Remi Collet <remi@remirepo.net> - 0.8.2-1
+- update to 0.8.2 (stable)
+- add optional dependency on psr extension
+
* Wed Jul 19 2017 Remi Collet <remi@remirepo.net> - 0.8.2~RC2-1
- update to 0.8.2RC2