summaryrefslogtreecommitdiffstats
path: root/php-pecl-grpc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-grpc.spec')
-rw-r--r--php-pecl-grpc.spec40
1 files changed, 6 insertions, 34 deletions
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index a2adaa6..ff34c38 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -15,8 +15,8 @@
%global pecl_name grpc
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.64.1
-#global upstream_prever RC2
+%global upstream_version 1.65.0
+%global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -30,14 +30,7 @@ Source0: https://pecl.php.net/get/%{sources}.tgz
Patch0: %{pecl_name}-build.patch
Patch1: %{pecl_name}-noatfork.patch
-Patch2: %{pecl_name}-gcc14.patch
-%if 0%{?rhel} == 7 && 0%{?dtsversion} < 7
-BuildRequires: devtoolset-7-toolchain
-%global dtsversion 7
-%global dtsenable source /opt/rh/devtoolset-7/enable
-%global dtsprefix devtoolset-7-
-%endif
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc >= 7.0
BuildRequires: %{?dtsprefix}gcc-c++
@@ -69,7 +62,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -77,9 +70,6 @@ cd %{sources}
%ifarch %{arm}
%patch -P1 -p1 -b .noatfork
%endif
-pushd third_party/boringssl-with-bazel/src
-%patch -P2 -p1 -b .gcc14
-popd
#sed -e '/PHP_GRPC_VERSION/s/RC3/RC2/' -i src/php/ext/grpc/version.h
@@ -158,26 +148,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
: Minimal load test for NTS extension
cd NTS
@@ -195,7 +165,6 @@ cd ../ZTS
%files
-%{!?_licensedir:%global license %%doc}
%license %{sources}/LICENSE
%{pecl_xmldir}/%{name}.xml
@@ -209,6 +178,9 @@ cd ../ZTS
%changelog
+* Mon Jul 8 2024 Remi Collet <remi@remirepo.net> - 1.65.0~RC2-1
+- update to 1.65.0RC2
+
* Mon Jun 3 2024 Remi Collet <remi@remirepo.net> - 1.64.1-1
- update to 1.64.1