summaryrefslogtreecommitdiffstats
path: root/php-pecl-grpc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-grpc.spec')
-rw-r--r--php-pecl-grpc.spec24
1 files changed, 21 insertions, 3 deletions
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index 5f2eeaf..bd6bae5 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -14,21 +14,22 @@
%global pecl_name grpc
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.62.0
-%global upstream_prever RC1
+%global upstream_version 1.63.0
+#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
Summary: General RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
Patch0: %{pecl_name}-build.patch
Patch1: %{pecl_name}-noatfork.patch
+Patch2: %{pecl_name}-gcc14.patch
%if 0%{?rhel} == 7 && 0%{?dtsversion} < 7
BuildRequires: devtoolset-7-toolchain
@@ -75,6 +76,9 @@ cd %{sources}
%ifarch %{arm}
%patch -P1 -p1 -b .noatfork
%endif
+pushd third_party/boringssl-with-bazel/src
+%patch -P2 -p1 -b .gcc14
+popd
#sed -e '/PHP_GRPC_VERSION/s/RC3/RC2/' -i src/php/ext/grpc/version.h
@@ -204,8 +208,22 @@ cd ../ZTS
%changelog
+* Fri May 17 2024 Remi Collet <remi@remirepo.net> - 1.63.0-2
+- add boringssl upstream patch for GCC 14
+
+* Wed May 1 2024 Remi Collet <remi@remirepo.net> - 1.63.0-1
+- update to 1.63.0
+
+* Wed Apr 17 2024 Remi Collet <remi@remirepo.net> - 1.63.0~RC1-1
+- update to 1.63.0RC1
+
+* Thu Feb 22 2024 Remi Collet <remi@remirepo.net> - 1.62.0-1
+- update to 1.62.0
+
* Tue Feb 20 2024 Remi Collet <remi@remirepo.net> - 1.62.0~RC1-1
- update to 1.62.0RC1
+- report broken build using GCC 14 on Fedora 40
+ https://github.com/grpc/grpc/issues/35945
* Tue Feb 6 2024 Remi Collet <remi@remirepo.net> - 1.61.0-1
- update to 1.61.0