summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--grpc-build.patch8
-rw-r--r--grpc-noatfork.patch8
-rw-r--r--php-pecl-grpc.spec5
5 files changed, 15 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 703e393..af75c39 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
grpc
grpc support => enabled
-grpc module version => 1.46.3
+grpc module version => 1.47.0
Directive => Local Value => Master Value
grpc.enable_fork_support => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index e624110..f621676 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 grpc version 1.46.3 ] {
+Extension [ <persistent> extension #118 grpc version 1.47.0 ] {
- INI {
Entry [ grpc.enable_fork_support <SYSTEM> ]
@@ -60,7 +60,7 @@ Extension [ <persistent> extension #120 grpc version 1.46.3 ] {
Constant [ int Grpc\CHANNEL_READY ] { 2 }
Constant [ int Grpc\CHANNEL_TRANSIENT_FAILURE ] { 3 }
Constant [ int Grpc\CHANNEL_FATAL_FAILURE ] { 4 }
- Constant [ string Grpc\VERSION ] { 1.46.3 }
+ Constant [ string Grpc\VERSION ] { 1.47.0 }
}
- Classes [7] {
diff --git a/grpc-build.patch b/grpc-build.patch
index 4d15462..fca67c4 100644
--- a/grpc-build.patch
+++ b/grpc-build.patch
@@ -1,14 +1,14 @@
diff -up ./config.m4.rpm ./config.m4
---- ./config.m4.rpm 2022-03-28 08:02:01.063993366 +0200
-+++ ./config.m4 2022-03-28 08:04:44.843398916 +0200
+--- ./config.m4.rpm 2022-07-07 07:28:31.928904255 +0200
++++ ./config.m4 2022-07-07 07:30:39.835689129 +0200
@@ -18,8 +18,8 @@ if test "$PHP_GRPC" != "no"; then
LIBS="-lpthread $LIBS"
- CFLAGS="-std=c11 -g -O2"
-- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti -g -O2"
+- CXXFLAGS="-std=c++14 -fno-exceptions -fno-rtti -g -O2"
+ CFLAGS="$CFLAGS -std=c11"
-+ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti"
++ CXXFLAGS="$CXXFLAGS -std=c++14 -fno-exceptions -fno-rtti"
GRPC_SHARED_LIBADD="-lpthread $GRPC_SHARED_LIBADD"
PHP_REQUIRE_CXX()
PHP_ADD_LIBRARY(pthread)
diff --git a/grpc-noatfork.patch b/grpc-noatfork.patch
index 59b0541..b78829b 100644
--- a/grpc-noatfork.patch
+++ b/grpc-noatfork.patch
@@ -1,11 +1,11 @@
diff -up ./config.m4.noatfork ./config.m4
---- ./config.m4.noatfork 2022-01-31 14:03:14.032856870 +0100
-+++ ./config.m4 2022-01-31 14:07:39.424150191 +0100
-@@ -1102,7 +1102,6 @@ if test "$PHP_GRPC" != "no"; then
+--- ./config.m4.noatfork 2022-07-07 07:30:58.524647576 +0200
++++ ./config.m4 2022-07-07 07:32:01.490513120 +0200
+@@ -1159,7 +1159,6 @@ if test "$PHP_GRPC" != "no"; then
, $ext_shared, , -fvisibility=hidden \
-DOPENSSL_NO_ASM -D_GNU_SOURCE -DWIN32_LEAN_AND_MEAN \
-D_HAS_EXCEPTIONS=0 -DNOMINMAX -DGRPC_ARES=0 \
- -DGRPC_POSIX_FORK_ALLOW_PTHREAD_ATFORK=1 \
-DGRPC_XDS_USER_AGENT_NAME_SUFFIX='"\"PHP\""' \
- -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.46.3\""')
+ -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.47.0\""')
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index e32ac46..d3fd96f 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -20,7 +20,7 @@
%global pecl_name grpc
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.46.3
+%global upstream_version 1.47.0
#global upstream_prever RC2
Summary: General RPC framework
@@ -229,6 +229,9 @@ cd ../ZTS
%changelog
+* Thu Jul 7 2022 Remi Collet <remi@remirepo.net> - 1.47.0-1
+- update to 1.47.0
+
* Thu May 26 2022 Remi Collet <remi@remirepo.net> - 1.46.3-1
- update to 1.46.3