summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--grpc-build.patch10
-rw-r--r--grpc-gcc91.patch66
-rw-r--r--grpc-noatfork.patch2
-rw-r--r--php-pecl-grpc.spec11
6 files changed, 14 insertions, 79 deletions
diff --git a/PHPINFO b/PHPINFO
index 4f41108..52287fe 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
grpc
grpc support => enabled
-grpc module version => 1.23.0
+grpc module version => 1.24.0RC1
Directive => Local Value => Master Value
grpc.enable_fork_support => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 2c9c097..c109809 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #200 grpc version 1.23.0 ] {
+Extension [ <persistent> extension #200 grpc version 1.24.0RC1 ] {
- INI {
Entry [ grpc.enable_fork_support <SYSTEM> ]
diff --git a/grpc-build.patch b/grpc-build.patch
index f212fc0..e903511 100644
--- a/grpc-build.patch
+++ b/grpc-build.patch
@@ -1,14 +1,14 @@
diff -up ./config.m4.rpm ./config.m4
--- ./config.m4.rpm 2018-04-09 09:53:39.927037294 +0200
+++ ./config.m4 2018-04-09 09:54:28.015307629 +0200
-@@ -12,8 +12,8 @@ if test "$PHP_GRPC" != "no"; then
+@@ -14,8 +14,8 @@ if test "$PHP_GRPC" != "no"; then
LIBS="-lpthread $LIBS"
-- CFLAGS="-Wall -Werror -Wno-parentheses-equality -Wno-unused-value -std=c11 -g -O2 -D PB_FIELD_32BIT=1"
-- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti -g -O2 -D PB_FIELD_32BIT=1"
-+ CFLAGS="$CFLAGS -std=c11 -D PB_FIELD_32BIT=1"
-+ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti -D PB_FIELD_32BIT=1"
+- CFLAGS="-Wall -Werror -Wno-parentheses-equality -Wno-unused-value -std=c11 -g -O2"
+- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti -g -O2"
++ CFLAGS="$CFLAGS -std=c11"
++ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti"
GRPC_SHARED_LIBADD="-lpthread $GRPC_SHARED_LIBADD"
PHP_REQUIRE_CXX()
PHP_ADD_LIBRARY(pthread)
diff --git a/grpc-gcc91.patch b/grpc-gcc91.patch
deleted file mode 100644
index 6e6be27..0000000
--- a/grpc-gcc91.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From de6255941a5e1c2fb2d50e57f84e38c09f45023d Mon Sep 17 00:00:00 2001
-From: Juanli Shen <juanlishen@google.com>
-Date: Fri, 23 Aug 2019 08:46:09 -0700
-Subject: [PATCH] Fix gettid() naming conflict
-
----
- src/core/lib/gpr/log_linux.cc | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/lib/gpr/log_linux.cc b/src/core/lib/gpr/log_linux.cc
-index 561276f0c20..81026e5689b 100644
---- a/src/core/lib/gpr/log_linux.cc
-+++ b/src/core/lib/gpr/log_linux.cc
-@@ -40,7 +40,9 @@
- #include <time.h>
- #include <unistd.h>
-
--static long gettid(void) { return syscall(__NR_gettid); }
-+// Not naming it as gettid() to avoid duplicate declarations when complied with
-+// GCC 9.1.
-+static long local_gettid(void) { return syscall(__NR_gettid); }
-
- void gpr_log(const char* file, int line, gpr_log_severity severity,
- const char* format, ...) {
-@@ -70,7 +72,7 @@ void gpr_default_log(gpr_log_func_args* args) {
- gpr_timespec now = gpr_now(GPR_CLOCK_REALTIME);
- struct tm tm;
- static __thread long tid = 0;
-- if (tid == 0) tid = gettid();
-+ if (tid == 0) tid = local_gettid();
-
- timer = static_cast<time_t>(now.tv_sec);
- final_slash = strrchr(args->file, '/');
-
-
-From c0763be75f4cd9216e89c22fb30449d38b83b74c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Sat, 24 Aug 2019 07:57:56 +0200
-Subject: [PATCH] fix gettid() naming conflict
-
----
- src/core/lib/iomgr/ev_epollex_linux.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/lib/iomgr/ev_epollex_linux.cc b/src/core/lib/iomgr/ev_epollex_linux.cc
-index c2d80c08ddb..aec4d813610 100644
---- a/src/core/lib/iomgr/ev_epollex_linux.cc
-+++ b/src/core/lib/iomgr/ev_epollex_linux.cc
-@@ -1077,7 +1077,7 @@ static void end_worker(grpc_pollset* pollset, grpc_pollset_worker* worker,
- }
-
- #ifndef NDEBUG
--static long gettid(void) { return syscall(__NR_gettid); }
-+static long local_gettid(void) { return syscall(__NR_gettid); }
- #endif
-
- /* pollset->mu lock must be held by the caller before calling this.
-@@ -1097,7 +1097,7 @@ static grpc_error* pollset_work(grpc_pollset* pollset,
- #define WORKER_PTR (&worker)
- #endif
- #ifndef NDEBUG
-- WORKER_PTR->originator = gettid();
-+ WORKER_PTR->originator = local_gettid();
- #endif
- if (GRPC_TRACE_FLAG_ENABLED(grpc_polling_trace)) {
- gpr_log(GPR_INFO,
diff --git a/grpc-noatfork.patch b/grpc-noatfork.patch
index eececca..fcf7af8 100644
--- a/grpc-noatfork.patch
+++ b/grpc-noatfork.patch
@@ -1,7 +1,7 @@
diff -Naurp a/NTS/config.m4 b/NTS/config.m4
--- a/NTS/config.m4 2019-07-05 09:18:10.983115724 +0000
+++ b/NTS/config.m4 2019-07-18 16:03:38.791414805 +0000
-@@ -681,7 +681,7 @@ if test "$PHP_GRPC" != "no"; then
+@@ -724,7 +724,7 @@ if test "$PHP_GRPC" != "no"; then
, $ext_shared, , -fvisibility=hidden \
-DOPENSSL_NO_ASM -D_GNU_SOURCE -DWIN32_LEAN_AND_MEAN \
-D_HAS_EXCEPTIONS=0 -DNOMINMAX -DGRPC_ARES=0 \
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index c8ba75d..f1dd231 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -24,20 +24,19 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 1.23.0
-#global upstream_prever RC1
+%global upstream_version 1.24.0
+%global upstream_prever RC1
Summary: General RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
Patch0: %{pecl_name}-build.patch
Patch1: %{pecl_name}-noatfork.patch
-Patch2: %{pecl_name}-gcc91.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -109,7 +108,6 @@ cd NTS
%ifarch %{arm}
%patch1 -p2 -b .noatfork
%endif
-%patch2 -p1 -b .gcc91
# Sanity check, really often broken
extver=$(sed -n '/PHP_GRPC_VERSION/{s/.* "//;s/".*$//;p}' src/php/ext/grpc/version.h)
@@ -233,6 +231,9 @@ cd ../ZTS
%changelog
+* Thu Sep 12 2019 Remi Collet <remi@remirepo.net> - 1.24.0~RC1-1
+- Update to 1.24.0RC1
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.23.0-3
- rebuild for 7.4.0RC1