summaryrefslogtreecommitdiffstats
path: root/php-pecl-grpc.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-20 08:00:00 +0200
committerRemi Collet <remi@php.net>2023-08-20 08:00:00 +0200
commitf75cdda6e0cda2bfd8e85d063132a9333469e174 (patch)
treed75495738a3b62cda0d52961e1e2be31560bf50c /php-pecl-grpc.spec
parenta55bef49bdd8d3aac6cc10734b9eedd916164595 (diff)
update to 1.57.0
build out of sources tree
Diffstat (limited to 'php-pecl-grpc.spec')
-rw-r--r--php-pecl-grpc.spec50
1 files changed, 25 insertions, 25 deletions
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index c043df9..1438de5 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -7,20 +7,17 @@
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
-%if 0%{?scl:1}
-%scl_package php-pecl-grpc
-%endif
+%{?scl:%scl_package php-pecl-grpc}
## TODO: not suitable for Fedora, tons of bundled libraries
-%global pecl_name grpc
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.56.0
+%global pecl_name grpc
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global upstream_version 1.57.0
#global upstream_prever RC1
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
Summary: General RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
@@ -28,7 +25,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: Apache-2.0
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
Patch0: %{pecl_name}-build.patch
Patch1: %{pecl_name}-noatfork.patch
@@ -48,7 +45,6 @@ BuildRequires: zlib-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -68,14 +64,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
%patch -P0 -p1 -b .rpm
%ifarch %{arm}
%patch -P1 -p1 -b .noatfork
@@ -91,9 +86,9 @@ if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -113,22 +108,23 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--enable-grpc \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-grpc \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -153,7 +149,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -182,20 +178,20 @@ fi
cd NTS
%{__php} --no-php-ini \
--define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
cd ../ZTS
%{__ztsphp} --no-php-ini \
--define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
%files
%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
+%license %{sources}/LICENSE
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -208,6 +204,10 @@ cd ../ZTS
%changelog
+* Sat Aug 19 2023 Remi Collet <remi@remirepo.net> - 1.57.0-1
+- update to 1.57.0
+- build out of sources tree
+
* Mon Jun 19 2023 Remi Collet <remi@remirepo.net> - 1.56.0-1
- update to 1.56.0