summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 09:27:24 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 09:27:24 +0200
commitb7b8b24a03d3af656e5dd1f786827ce50cb8e03f (patch)
tree5a0632e0125f8d1b90f77a2287f3383960aa4a48
parent4a7c20eb8a5734c6c409fc4a0d15a27eee8e8275 (diff)
v1.6.0RC1
-rw-r--r--REFLECTION2
-rw-r--r--grpc-build.patch4
-rw-r--r--php-pecl-grpc.spec12
3 files changed, 11 insertions, 7 deletions
diff --git a/REFLECTION b/REFLECTION
index b1f5c09..4d3386e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #182 grpc version 1.4.6 ] {
+Extension [ <persistent> extension #184 grpc version 1.6.0RC1 ] {
- Constants [41] {
Constant [ integer Grpc\CALL_OK ] { 0 }
diff --git a/grpc-build.patch b/grpc-build.patch
index 9c935c5..efff313 100644
--- a/grpc-build.patch
+++ b/grpc-build.patch
@@ -6,9 +6,9 @@ diff -up ./config.m4.rpm ./config.m4
LIBS="-lpthread $LIBS"
- CFLAGS="-Wall -Werror -Wno-parentheses-equality -Wno-unused-value -std=c11"
-- CXXFLAGS="-std=c++11"
+- CXXFLAGS="-std=c++11 -fno-exceptions -fno-rtti"
+ CFLAGS="$CFLAGS -Wno-parentheses-equality -Wno-unused-value -std=c11"
-+ CXXFLAGS="$CXXFLAGS -std=c++11"
++ CXXFLAGS="$CXXFLAGS -std=c++11 -fno-exceptions -fno-rtti"
GRPC_SHARED_LIBADD="-lpthread $GRPC_SHARED_LIBADD"
PHP_REQUIRE_CXX()
PHP_ADD_LIBRARY(pthread)
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index 89d6caf..1768810 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -21,14 +21,14 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 1.4.6
-#global upstream_prever RC6
+%global upstream_version 1.6.0
+%global upstream_prever RC1
Summary: General RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: MIT
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -221,6 +221,10 @@ cd ../ZTS
%changelog
+* Mon Sep 4 2017 Remi Collet <remi@remirepo.net> - 1.6.0~RC1-1
+- Update to 1.6.0RC1
+- License changed to Apache 2.0
+
* Tue Aug 22 2017 Remi Collet <remi@remirepo.net> - 1.4.6-2
- honour default RPM build options