summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-02 11:28:48 +0100
committerRemi Collet <remi@php.net>2023-03-02 11:28:48 +0100
commit89297d6d181ec23fc2975f40bcd72a324ebfb12a (patch)
tree5d3d2ac2866f111103d9aa6ae8ee2490e8746a5d
parent209abe7bae9211b03ee074517ec1a585cf5af383 (diff)
update to 1.53.0RC1
use GCC 7 on EL-7 with PHP <= 7.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--grpc-noatfork.patch2
-rw-r--r--php-pecl-grpc.spec20
4 files changed, 16 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 58359c5..0069940 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
grpc
grpc support => enabled
-grpc module version => 1.52.1
+grpc module version => 1.53.0RC1
Directive => Local Value => Master Value
grpc.enable_fork_support => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 2930b76..b73be18 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 grpc version 1.52.1 ] {
+Extension [ <persistent> extension #122 grpc version 1.53.0RC1 ] {
- INI {
Entry [ grpc.enable_fork_support <SYSTEM> ]
@@ -60,7 +60,7 @@ Extension [ <persistent> extension #122 grpc version 1.52.1 ] {
Constant [ int Grpc\CHANNEL_READY ] { 2 }
Constant [ int Grpc\CHANNEL_TRANSIENT_FAILURE ] { 3 }
Constant [ int Grpc\CHANNEL_FATAL_FAILURE ] { 4 }
- Constant [ string Grpc\VERSION ] { 1.52.1 }
+ Constant [ string Grpc\VERSION ] { 1.53.0RC1 }
}
- Classes [7] {
diff --git a/grpc-noatfork.patch b/grpc-noatfork.patch
index d6471c4..b12961e 100644
--- a/grpc-noatfork.patch
+++ b/grpc-noatfork.patch
@@ -7,5 +7,5 @@ diff -up ./config.m4.noatfork ./config.m4
-D_HAS_EXCEPTIONS=0 -DNOMINMAX -DGRPC_ARES=0 \
- -DGRPC_POSIX_FORK_ALLOW_PTHREAD_ATFORK=1 \
-DGRPC_XDS_USER_AGENT_NAME_SUFFIX='"\"PHP\""' \
- -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.52.1\""')
+ -DGRPC_XDS_USER_AGENT_VERSION_SUFFIX='"\"1.53.0RC1\""')
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index d630374..25f88e1 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -19,8 +19,8 @@
%global pecl_name grpc
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.52.1
-#global upstream_prever RC1
+%global upstream_version 1.53.0
+%global upstream_prever RC1
Summary: General RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
@@ -33,14 +33,14 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
Patch0: %{pecl_name}-build.patch
Patch1: %{pecl_name}-noatfork.patch
-%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
-BuildRequires: devtoolset-6-toolchain
-%global dtsversion 6
-%global dtsenable source /opt/rh/devtoolset-6/enable
-%global dtsprefix devtoolset-6-
+%if 0%{?rhel} == 7 && 0%{?dtsversion} < 7
+BuildRequires: devtoolset-7-toolchain
+%global dtsversion 7
+%global dtsenable source /opt/rh/devtoolset-7/enable
+%global dtsprefix devtoolset-7-
%endif
BuildRequires: make
-BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc >= 7
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
@@ -208,6 +208,10 @@ cd ../ZTS
%changelog
+* Thu Mar 2 2023 Remi Collet <remi@remirepo.net> - 1.53.0~RC1-1
+- update to 1.53.0RC1
+- use GCC 7 on EL-7 with PHP <= 7.2
+
* Mon Feb 27 2023 Remi Collet <remi@remirepo.net> - 1.52.1-1
- update to 1.52.1