summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Greco <pgreco@centosproject.org>2019-07-18 12:13:07 +0000
committerRemi Collet <remi@remirepo.net>2019-07-18 14:18:33 +0200
commit61e61e419d19562cb1cec9c6e4857db88f06988c (patch)
tree7776fd2991636e29b0225ffd28abbb4449bc00b9
parent4500fbaf79b83e623080b25cc8e3489bd74a1903 (diff)
pthread_atfork is not exported in armhfp, avoid it
-rw-r--r--grpc-noatfork.patch12
-rw-r--r--php-pecl-grpc.spec9
2 files changed, 20 insertions, 1 deletions
diff --git a/grpc-noatfork.patch b/grpc-noatfork.patch
new file mode 100644
index 0000000..85c932b
--- /dev/null
+++ b/grpc-noatfork.patch
@@ -0,0 +1,12 @@
+diff -Naurp a/NTS/config.m4 b/NTS/config.m4
+--- a/NTS/config.m4 2019-07-05 09:18:10.983115724 +0000
++++ b/NTS/config.m4 2019-07-05 09:19:27.877275179 +0000
+@@ -681,7 +681,7 @@ if test "$PHP_GRPC" != "no"; then
+ , $ext_shared, , -fvisibility=hidden \
+ -DOPENSSL_NO_ASM -D_GNU_SOURCE -DWIN32_LEAN_AND_MEAN \
+ -D_HAS_EXCEPTIONS=0 -DNOMINMAX -DGRPC_ARES=0 \
+- -DGRPC_POSIX_FORK_ALLOW_PTHREAD_ATFORK=1)
++ -DGRPC_POSIX_FORK_ALLOW_PTHREAD_ATFORK=0)
+
+ PHP_ADD_BUILD_DIR($ext_builddir/src/php/ext/grpc)
+
diff --git a/php-pecl-grpc.spec b/php-pecl-grpc.spec
index 9e68507..e110e04 100644
--- a/php-pecl-grpc.spec
+++ b/php-pecl-grpc.spec
@@ -30,12 +30,13 @@
Summary: General RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
Patch0: %{pecl_name}-build.patch
+Patch1: %{pecl_name}-noatfork.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -104,6 +105,9 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
%patch0 -p1 -b .rpm
+%ifarch %{arm}
+%patch1 -p2 -b .noatfork
+%endif
# Sanity check, really often broken
extver=$(sed -n '/PHP_GRPC_VERSION/{s/.* "//;s/".*$//;p}' src/php/ext/grpc/version.h)
@@ -227,6 +231,9 @@ cd ../ZTS
%changelog
+* Thu Jul 18 2019 Pablo Greco <pgreco@centosproject.org> - 1.22.0-2
+- Fix build on armhfp, pthread_atfork not exported
+
* Thu Jul 4 2019 Remi Collet <remi@remirepo.net> - 1.22.0-1
- Update to 1.22.0