summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 13:11:30 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 13:11:30 +0100
commit5ac6f7d8376c531e00424f2009039c3b8ed617d3 (patch)
treebfe8a61100af04b14b806c32b0761d79667ba8f3
parent1193baa030f2d067d60ef954dba10612f6b0b136 (diff)
php-pecl-graphdat: F24
-rw-r--r--php-pecl-graphdat.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/php-pecl-graphdat.spec b/php-pecl-graphdat.spec
index c97b47a..b5957e2 100644
--- a/php-pecl-graphdat.spec
+++ b/php-pecl-graphdat.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-graphdat}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name graphdat
%global with_zts 0%{?__ztsphp:1}
@@ -27,7 +24,7 @@
Summary: Troubleshoot application and server performance
Name: %{?scl_prefix}php-pecl-graphdat
Version: 1.0.4
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# https://github.com/alphashack/graphdat-sdk-php/issues/6
License: ASL 2.0
Group: Development/Languages
@@ -45,10 +42,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -93,6 +92,7 @@ sed -e 's/role="test"/role="src"/' \
%if %{with_msgpack}
-e '\:name="src/msgpack:d' \
%endif
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
mv %{pecl_name}-%{version} NTS
@@ -195,6 +195,7 @@ done
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -211,6 +212,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -233,6 +235,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-3
+- adapt for F24
+
* Tue Jan 19 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-2
- rebuild with bundled msgpack on F23
- open https://github.com/alphashack/graphdat-sdk-php/issues/8
@@ -247,4 +252,4 @@ rm -rf %{buildroot}
* Fri Sep 19 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
- initial package, version 1.0.3 (stable)
- open https://github.com/alphashack/graphdat-sdk-php/pull/5
-- open https://github.com/alphashack/graphdat-sdk-php/issues/6 \ No newline at end of file
+- open https://github.com/alphashack/graphdat-sdk-php/issues/6