summaryrefslogtreecommitdiffstats
path: root/php-pecl-gnupg.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 09:58:41 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 09:58:41 +0200
commita6420ff8312f5828314fae3b45d4ecd42569dfd6 (patch)
treee2c1425e8cc88d277b9815614f79bc5bba1babcf /php-pecl-gnupg.spec
parent1170ac91cf4056f42b70d12cdf31f1b89ac1afd4 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
Diffstat (limited to 'php-pecl-gnupg.spec')
-rw-r--r--php-pecl-gnupg.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-gnupg.spec b/php-pecl-gnupg.spec
index 871404a..ec16196 100644
--- a/php-pecl-gnupg.spec
+++ b/php-pecl-gnupg.spec
@@ -13,11 +13,16 @@
%global pecl_name gnupg
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Wrapper around the gpgme library
Name: %{?scl_prefix}php-pecl-gnupg
Version: 1.3.3
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -77,7 +82,7 @@ Documentation : http://www.php.net/gnupg
%setup -c -q
# Create configuration file
-cat >%{pecl_name}.ini << 'EOF'
+cat >%{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -127,14 +132,14 @@ rm -rf %{buildroot}
make install -C NTS INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make install -C ZTS INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -216,16 +221,19 @@ NO_INTERACTION=1 \
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.3.3-4
+- add numerical prefix to extension configuration file
+
* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 1.3.3-3
- allow SCL build