summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 11:31:18 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 11:31:18 +0100
commitf2bfdd303fa26f091b6d44a34f75b59f2e3a8e19 (patch)
tree4f3d0d55d52b1547090f40269532770b4831859f
parent4f1e045d2baa47e96985524ecd250007353ac5a9 (diff)
php-pecl-gnupg: F24
-rw-r--r--php-pecl-gnupg.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-gnupg.spec b/php-pecl-gnupg.spec
index 0606233..7567bac 100644
--- a/php-pecl-gnupg.spec
+++ b/php-pecl-gnupg.spec
@@ -7,9 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-gnupg}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name gnupg
%global with_zts 0%{?__ztsphp:1}
@@ -22,7 +19,7 @@
Summary: Wrapper around the gpgme library
Name: %{?scl_prefix}php-pecl-gnupg
Version: 1.3.6
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -41,10 +38,12 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: gnupg
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -74,14 +73,16 @@ This module allows you to interact with gnupg.
Documentation : http://www.php.net/gnupg
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -c -q
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
# Create configuration file
cat >%{ini_name} << 'EOF'
@@ -153,6 +154,7 @@ done
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -169,6 +171,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -237,6 +240,9 @@ NO_INTERACTION=1 \
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.3.6-2
+- adapt for F24
+
* Thu Feb 12 2015 Remi Collet <remi@fedoraproject.org> - 1.3.6-1
- Update to 1.3.6
- don't install test suite