summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-25 07:32:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-25 07:32:11 +0200
commit379ab6beb494f3a9a83c609b5a26fd35c3a6b7cc (patch)
tree0841a5f8117d2ba8ee79bafd89d13eb6f116972c
parent4744bd8c677cc7489d56382c6307d5eeb58ad2b1 (diff)
php-pecl-gnupg: 1.4.0RC2
-rw-r--r--REFLECTION2
-rw-r--r--gnupg-pr1.patch91
-rw-r--r--php-pecl-gnupg.spec10
3 files changed, 6 insertions, 97 deletions
diff --git a/REFLECTION b/REFLECTION
index fa6e29f..e9cc34a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 gnupg version 1.4.0RC1 ] {
+Extension [ <persistent> extension #85 gnupg version 1.4.0RC2 ] {
- Constants [25] {
Constant [ integer GNUPG_SIG_MODE_NORMAL ] { 0 }
diff --git a/gnupg-pr1.patch b/gnupg-pr1.patch
deleted file mode 100644
index c1f2f73..0000000
--- a/gnupg-pr1.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 32203934c7c4a624b54e2d5822a523fec14b1e7a Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 16 Jun 2016 11:09:56 +0200
-Subject: [PATCH] Fix callbacks prototype, to match exactly what expected.
-
-This is broken on ZTS, as the additional parameter (TRSMLS)
-will never be sent by libgpgme.
-
-The cast was badly hdding the warning about this.
----
- gnupg.c | 20 ++++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/gnupg.c b/gnupg.c
-index af20050..3ff4f09 100644
---- a/gnupg.c
-+++ b/gnupg.c
-@@ -395,14 +395,16 @@ PHP_MINFO_FUNCTION(gnupg)
-
- /* {{{ passphrase_cb */
- gpgme_error_t passphrase_cb(
-- PHPC_THIS_DECLARE(gnupg),
-+ void *hook,
- const char *uid_hint, const char *passphrase_info,
-- int last_was_bad, int fd TSRMLS_DC)
-+ int last_was_bad, int fd)
- {
- char uid[17];
- int idx;
- char *passphrase = NULL;
- zval *return_value = NULL;
-+ PHPC_THIS_DECLARE(gnupg) = hook;
-+ TSRMLS_FETCH();
-
- if (last_was_bad) {
- GNUPG_ERR("Incorrent passphrase");
-@@ -431,14 +433,16 @@ gpgme_error_t passphrase_cb(
-
- /* {{{ passphrase_decrypt_cb */
- gpgme_error_t passphrase_decrypt_cb (
-- PHPC_THIS_DECLARE(gnupg),
-+ void *hook,
- const char *uid_hint, const char *passphrase_info,
-- int last_was_bad, int fd TSRMLS_DC)
-+ int last_was_bad, int fd)
- {
- char uid[17];
- int idx;
- char *passphrase = NULL;
- zval *return_value = NULL;
-+ PHPC_THIS_DECLARE(gnupg) = hook;
-+ TSRMLS_FETCH();
-
- if (last_was_bad) {
- GNUPG_ERR("Incorrent passphrase");
-@@ -927,7 +931,7 @@ PHP_FUNCTION(gnupg_sign)
- GNUPG_RES_FETCH();
- }
-
-- gpgme_set_passphrase_cb(PHPC_THIS->ctx, (void *)passphrase_cb, PHPC_THIS);
-+ gpgme_set_passphrase_cb(PHPC_THIS->ctx, passphrase_cb, PHPC_THIS);
- if ((PHPC_THIS->err = gpgme_data_new_from_mem(&in, value, value_len, 0)) != GPG_ERR_NO_ERROR) {
- GNUPG_ERR("could not create in-data buffer");
- return;
-@@ -1063,7 +1067,7 @@ PHP_FUNCTION(gnupg_encryptsign)
- GNUPG_ERR("no key for encryption set");
- return;
- }
-- gpgme_set_passphrase_cb(PHPC_THIS->ctx, (void *)passphrase_cb, PHPC_THIS);
-+ gpgme_set_passphrase_cb(PHPC_THIS->ctx, passphrase_cb, PHPC_THIS);
- if ((PHPC_THIS->err = gpgme_data_new_from_mem (&in, value, value_len, 0)) != GPG_ERR_NO_ERROR) {
- GNUPG_ERR("could not create in-data buffer");
- return;
-@@ -1227,7 +1231,7 @@ PHP_FUNCTION(gnupg_decrypt)
- GNUPG_RES_FETCH();
- }
-
-- gpgme_set_passphrase_cb(PHPC_THIS->ctx, (void *)passphrase_decrypt_cb, PHPC_THIS);
-+ gpgme_set_passphrase_cb(PHPC_THIS->ctx, passphrase_decrypt_cb, PHPC_THIS);
-
- if ((PHPC_THIS->err = gpgme_data_new_from_mem(&in, enctxt, enctxt_len, 0)) != GPG_ERR_NO_ERROR) {
- GNUPG_ERR("could not create in-data buffer");
-@@ -1291,7 +1295,7 @@ PHP_FUNCTION(gnupg_decryptverify)
- }
- PHPC_PZVAL_DEREF(plaintext);
-
-- gpgme_set_passphrase_cb(PHPC_THIS->ctx, (void *)passphrase_decrypt_cb, PHPC_THIS);
-+ gpgme_set_passphrase_cb(PHPC_THIS->ctx, passphrase_decrypt_cb, PHPC_THIS);
-
- if ((PHPC_THIS->err = gpgme_data_new_from_mem(&in, enctxt, enctxt_len, 0)) != GPG_ERR_NO_ERROR) {
- GNUPG_ERR("could not create in-data buffer");
diff --git a/php-pecl-gnupg.spec b/php-pecl-gnupg.spec
index 525dc50..90467ba 100644
--- a/php-pecl-gnupg.spec
+++ b/php-pecl-gnupg.spec
@@ -23,20 +23,18 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever RC1
+%global prever RC2
Summary: Wrapper around the gpgme library
Name: %{?sub_prefix}php-pecl-gnupg
Version: 1.4.0
-Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/gnupg
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: %{pecl_name}-pr1.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -113,7 +111,6 @@ EOF
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch0 -p1 -b .pr1
# Check extension version
extver=$(sed -n '/#define PHP_GNUPG_VERSION/{s/.* "//;s/".*$//;p}' php_gnupg.h)
@@ -263,6 +260,9 @@ NO_INTERACTION=1 \
%changelog
+* Mon Jul 25 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.3.RC2
+- update to 1.4.0RC2 (beta)
+
* Fri Jun 17 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.2.RC1
- always use gnupg < 2