summaryrefslogtreecommitdiffstats
path: root/php-pecl-gmagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-gmagick.spec')
-rw-r--r--php-pecl-gmagick.spec87
1 files changed, 68 insertions, 19 deletions
diff --git a/php-pecl-gmagick.spec b/php-pecl-gmagick.spec
index 13220ee..60d4d6d 100644
--- a/php-pecl-gmagick.spec
+++ b/php-pecl-gmagick.spec
@@ -7,16 +7,20 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-gmagick}
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-gmagick
+%endif
%global pecl_name gmagick
-%global prever RC3
-%global with_zts 0%{?__ztsphp:1}
+%global prever RC1
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
Summary: Provides a wrapper to the GraphicsMagick library
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.7
-Release: 0.7.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 2.0.4
+Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Libraries
URL: http://pecl.php.net/package/%{pecl_name}
@@ -24,8 +28,8 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: GraphicsMagick-devel >= 1.2.6
+BuildRequires: %{?scl_prefix}php-devel >= 7.0.1
+BuildRequires: GraphicsMagick-devel >= 1.3.17
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -35,8 +39,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
Conflicts: %{?scl_prefix}php-pecl-imagick
Conflicts: %{?scl_prefix}php-magickwand
@@ -47,17 +53,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -94,7 +102,7 @@ fi
cd ..
# Create configuration file
-cat >%{pecl_name}.ini << 'EOF'
+cat >%{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -128,11 +136,11 @@ make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 664 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Drop in the bit of configuration
-install -D -m 664 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 664 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 664 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 664 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
@@ -199,19 +207,60 @@ export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.1.7-0.8.RC3
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.4-0.4.RC1
+- rebuild for PHP 7.2.0beta1 new API
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.4-0.3.RC1
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.4-0.2.RC1
+- rebuild for PHP 7.1 new API version
+
+* Mon Jun 27 2016 Remi Collet <remi@fedoraproject.org> - 2.0.4-0.1.RC1
+- Update to 2.0.4RC1 (php 7, beta)
+
+* Sun Jun 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-0.1.RC1
+- Update to 2.0.3RC1 (php 7, beta)
+
+* Fri Jun 24 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.4.RC2
+- add patch for PHP 7.1, https://github.com/vitoc/gmagick/pull/41
+
+* Fri Mar 11 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.3.RC2
+- Update to 2.0.2RC2 (php 7, beta)
+
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.2.RC1
- adapt for F24
+* Sat Feb 20 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.1.RC1
+- Update to 2.0.2RC1 (php 7, beta)
+
+* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-0.3.RC3
+- Update to 2.0.1RC3 (php 7, beta)
+
+* Sun Jan 31 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-0.2.RC2
+- Update to 2.0.1RC2 (php 7, beta)
+- lower dependency on GraphicsMagick >= 1.3.17
+- open https://github.com/vitoc/gmagick/issues/25
+- open https://github.com/vitoc/gmagick/issues/26
+
+* Tue Dec 29 2015 Remi Collet <remi@fedoraproject.org> - 2.0.1-0.1.RC1
+- Update to 2.0.1RC1 (php 7, beta)
+- lower dependency on GraphicsMagick >= 1.3.20
+
+* Tue Dec 29 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.RC1
+- Update to 2.0.0RC1 (php 7, beta)
+- raise dependency on GraphicsMagick >= 1.3.22
+
* Fri Apr 24 2015 Remi Collet <remi@fedoraproject.org> - 1.1.7-0.6.RC3
- Update to 1.1.7RC3 (beta)
- don't install/register tests