summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-26 07:24:44 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-26 07:24:44 +0200
commit20bc3e3ab7a2ef03b9c142a5dbd4d3feb723f4fb (patch)
treecd05b4caf73d911b5de18cd25edd75649bc41307
parent177a2ecea222328899e0d5446792387ce47b8cc6 (diff)
php-pecl-gmagick: 2.0.3RC1
-rw-r--r--REFLECTION-PHP710
-rw-r--r--gmagick-const.patch12
-rw-r--r--gmagick-pr41.patch24
-rw-r--r--php-pecl-gmagick-php7.spec16
4 files changed, 27 insertions, 35 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 11f1a9c..48e33fc 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #61 gmagick version 2.0.2RC2 ] {
+Extension [ <persistent> extension #62 gmagick version 2.0.3RC1 ] {
- Classes [5] {
Class [ <internal:gmagick> final class GmagickException extends Exception implements Throwable ] {
@@ -214,6 +214,7 @@ Extension [ <persistent> extension #61 gmagick version 2.0.2RC2 ] {
Constant [ integer COMPRESSION_LZW ] { 7 }
Constant [ integer COMPRESSION_RLE ] { 8 }
Constant [ integer COMPRESSION_ZIP ] { 9 }
+ Constant [ integer INTERLACE_NO ] { 1 }
Constant [ integer INTERLACE_NONE ] { 1 }
Constant [ integer INTERLACE_LINE ] { 2 }
Constant [ integer INTERLACE_PLANE ] { 3 }
@@ -337,7 +338,6 @@ Extension [ <persistent> extension #61 gmagick version 2.0.2RC2 ] {
Constant [ integer RENDERINGINTENT_ABSOLUTE ] { 3 }
Constant [ integer RENDERINGINTENT_RELATIVE ] { 4 }
Constant [ integer INTERLACE_UNDEFINED ] { 0 }
- Constant [ integer INTERLACE_NO ] { 1 }
Constant [ integer FILLRULE_UNDEFINED ] { 0 }
Constant [ integer FILLRULE_EVENODD ] { 1 }
Constant [ integer FILLRULE_NONZERO ] { 2 }
@@ -364,9 +364,9 @@ Extension [ <persistent> extension #61 gmagick version 2.0.2RC2 ] {
Constant [ integer DISPOSE_PREVIOUS ] { 3 }
Constant [ integer QUANTUM_DEPTH ] { 16 }
Constant [ integer QUANTUM ] { 131071 }
- Constant [ string VERSION_TXT ] { 1.3.23 }
- Constant [ integer VERSION_LIB ] { 1512449 }
- Constant [ integer VERSION_NUM ] { 1003023 }
+ Constant [ string VERSION_TXT ] { 1.3.24 }
+ Constant [ integer VERSION_LIB ] { 1578240 }
+ Constant [ integer VERSION_NUM ] { 1003024 }
}
- Static properties [0] {
diff --git a/gmagick-const.patch b/gmagick-const.patch
new file mode 100644
index 0000000..792b15e
--- /dev/null
+++ b/gmagick-const.patch
@@ -0,0 +1,12 @@
+diff --git a/gmagick_helpers.c b/gmagick_helpers.c
+index 88aab56..5e9d578 100644
+--- a/gmagick_helpers.c
++++ b/gmagick_helpers.c
+@@ -185,6 +185,7 @@ void php_gmagick_initialize_constants()
+ GMAGICK_REGISTER_CONST_LONG("COMPRESSION_JBIG2", JBIG2Compression);
+ #endif
+
++ GMAGICK_REGISTER_CONST_LONG("INTERLACE_NO", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_NONE", NoInterlace); //Don't interlace image (RGBRGBRGBRGBRGBRGB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_LINE", LineInterlace); //Use scanline interlacing (RRR...GGG...BBB...RRR...GGG...BBB...)
+ GMAGICK_REGISTER_CONST_LONG("INTERLACE_PLANE", PlaneInterlace);//Use plane interlacing (RRRRRR...GGGGGG...BBBBBB...)
diff --git a/gmagick-pr41.patch b/gmagick-pr41.patch
deleted file mode 100644
index 42932c3..0000000
--- a/gmagick-pr41.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From cbc919f4f7224e7217bffa89472b5d092cd30764 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 24 Jun 2016 12:54:29 +0200
-Subject: [PATCH] clean duplicate constant definition, fix #40
-
----
- gmagick_helpers.c | 4 ----
- 1 file changed, 4 deletions(-)
-
-diff --git a/gmagick_helpers.c b/gmagick_helpers.c
-index 9c8ed06..88aab56 100644
---- a/gmagick_helpers.c
-+++ b/gmagick_helpers.c
-@@ -341,10 +341,6 @@ void php_gmagick_initialize_constants()
- GMAGICK_REGISTER_CONST_LONG("RENDERINGINTENT_ABSOLUTE", AbsoluteIntent);
- GMAGICK_REGISTER_CONST_LONG("RENDERINGINTENT_RELATIVE", RelativeIntent);
- GMAGICK_REGISTER_CONST_LONG("INTERLACE_UNDEFINED", UndefinedInterlace);
-- GMAGICK_REGISTER_CONST_LONG("INTERLACE_NO", NoInterlace);
-- GMAGICK_REGISTER_CONST_LONG("INTERLACE_LINE", LineInterlace);
-- GMAGICK_REGISTER_CONST_LONG("INTERLACE_PLANE", PlaneInterlace);
-- GMAGICK_REGISTER_CONST_LONG("INTERLACE_PARTITION", PartitionInterlace);
- GMAGICK_REGISTER_CONST_LONG("FILLRULE_UNDEFINED", UndefinedRule);
- GMAGICK_REGISTER_CONST_LONG("FILLRULE_EVENODD", EvenOddRule);
- GMAGICK_REGISTER_CONST_LONG("FILLRULE_NONZERO", NonZeroRule);
diff --git a/php-pecl-gmagick-php7.spec b/php-pecl-gmagick-php7.spec
index c2876d5..1e23c80 100644
--- a/php-pecl-gmagick-php7.spec
+++ b/php-pecl-gmagick-php7.spec
@@ -13,21 +13,22 @@
%endif
%global pecl_name gmagick
-%global prever RC2
+%global prever RC1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
Summary: Provides a wrapper to the GraphicsMagick library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.2
-Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.3
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Libraries
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# https://github.com/vitoc/gmagick/pull/41 - for PHP 7.1
-Patch0: %{pecl_name}-pr41.patch
+# restore dropped constant by mistake
+# see https://github.com/vitoc/gmagick/pull/41#issuecomment-228584703
+Patch0: %{pecl_name}-const.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-pear
@@ -92,7 +93,7 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch0 -p1 -b .pr41
+%patch0 -p1 -b .const
extver=$(sed -n '/#define PHP_GMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_gmagick.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -217,6 +218,9 @@ export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%changelog
+* Sun Jun 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-0.1.RC1
+- Update to 2.0.3RC1 (php 7, beta)
+
* Fri Jun 24 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.4.RC2
- add patch for PHP 7.1, https://github.com/vitoc/gmagick/pull/41