summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-20 12:34:59 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-20 12:34:59 +0100
commit0257a6edd81e5ab2ef62442461611808beefdf7b (patch)
tree1a2cfc19624731494399ce329135e5239e4438f3
parent110ebddd76d1626c7956454e1c0498e67966f7b2 (diff)
php-pecl-gmagick: 2.0.2RC1 (php 7, beta)
-rw-r--r--REFLECTION-PHP719
-rw-r--r--php-pecl-gmagick-php7.spec15
2 files changed, 25 insertions, 9 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index f0d4c9a..b054a5f 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #59 gmagick version 2.0.1RC3 ] {
+Extension [ <persistent> extension #59 gmagick version 2.0.2RC1 ] {
- Classes [5] {
Class [ <internal:gmagick> final class GmagickException extends Exception implements Throwable ] {
@@ -2680,7 +2680,7 @@ Extension [ <persistent> extension #59 gmagick version 2.0.1RC3 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [8] {
Method [ <internal:gmagick, ctor> public method __construct ] {
- Parameters [1] {
@@ -2723,6 +2723,21 @@ Extension [ <persistent> extension #59 gmagick version 2.0.1RC3 ] {
Parameter #1 [ <required> $value ]
}
}
+
+ Method [ <internal:gmagick> public method getcolorvaluequantum ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $color ]
+ }
+ }
+
+ Method [ <internal:gmagick> public method setcolorvaluequantum ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $color ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
}
}
}
diff --git a/php-pecl-gmagick-php7.spec b/php-pecl-gmagick-php7.spec
index d3aa28c..1fba457 100644
--- a/php-pecl-gmagick-php7.spec
+++ b/php-pecl-gmagick-php7.spec
@@ -8,19 +8,15 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-gmagick}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
-
%global pecl_name gmagick
-%global prever RC3
+%global prever RC1
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
Summary: Provides a wrapper to the GraphicsMagick library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.1
-Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.2
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Libraries
URL: http://pecl.php.net/package/%{pecl_name}
@@ -39,6 +35,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
Conflicts: %{?scl_prefix}php-pecl-imagick
Conflicts: %{?scl_prefix}php-magickwand
@@ -203,6 +201,9 @@ export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
%changelog
+* Sat Feb 20 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-0.1.RC1
+- Update to 2.0.2RC1 (php 7, beta)
+
* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-0.3.RC3
- Update to 2.0.1RC3 (php 7, beta)