summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-geospatial.spec44
3 files changed, 23 insertions, 43 deletions
diff --git a/PHPINFO b/PHPINFO
index 35ee1b5..fb9a04d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
geospatial
Geospatial functions => enabled
-Version => 0.3.1
+Version => 0.3.2
diff --git a/REFLECTION b/REFLECTION
index 2a16eeb..1821bfc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
+Extension [ <persistent> extension #119 geospatial version 0.3.2 ] {
- Constants [4] {
Constant [ float GEO_DEG_TO_RAD ] { 0.017453292519943 }
@@ -13,7 +13,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $geoJsonPointFrom ]
Parameter #1 [ <required> $geoJsonPointTo ]
- Parameter #2 [ <optional> $radius ]
+ Parameter #2 [ <optional> $radius = <default> ]
}
}
Function [ <internal:geospatial> function initial_bearing ] {
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $geoJsonPointFrom ]
Parameter #1 [ <required> $geoJsonPointTo ]
- Parameter #2 [ <optional> $radius ]
+ Parameter #2 [ <optional> $radius = <default> ]
}
}
Function [ <internal:geospatial> function fraction_along_gc_line ] {
@@ -30,7 +30,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
Parameter #0 [ <required> $geoJsonPointFrom ]
Parameter #1 [ <required> $geoJsonPointTo ]
Parameter #2 [ <required> $fraction ]
- Parameter #3 [ <optional> $radius ]
+ Parameter #3 [ <optional> $radius = <default> ]
}
}
Function [ <internal:geospatial> function helmert ] {
@@ -39,8 +39,8 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
Parameter #0 [ <required> $x ]
Parameter #1 [ <required> $y ]
Parameter #2 [ <required> $z ]
- Parameter #3 [ <optional> $from_reference_ellipsoid ]
- Parameter #4 [ <optional> $to_reference_ellipsoid ]
+ Parameter #3 [ <optional> $from_reference_ellipsoid = <default> ]
+ Parameter #4 [ <optional> $to_reference_ellipsoid = <default> ]
}
}
Function [ <internal:geospatial> function polar_to_cartesian ] {
@@ -48,7 +48,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $latitude ]
Parameter #1 [ <required> $longitude ]
- Parameter #2 [ <required> $reference_ellipsoid ]
+ Parameter #2 [ <optional> $reference_ellipsoid = <default> ]
}
}
Function [ <internal:geospatial> function cartesian_to_polar ] {
@@ -57,7 +57,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
Parameter #0 [ <required> $x ]
Parameter #1 [ <required> $y ]
Parameter #2 [ <required> $z ]
- Parameter #3 [ <required> $reference_ellipsoid ]
+ Parameter #3 [ <optional> $reference_ellipsoid = <default> ]
}
}
Function [ <internal:geospatial> function transform_datum ] {
@@ -74,7 +74,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
Parameter #0 [ <required> $degrees ]
Parameter #1 [ <required> $minutes ]
Parameter #2 [ <required> $seconds ]
- Parameter #3 [ <optional> $direction ]
+ Parameter #3 [ <optional> $direction = <default> ]
}
}
Function [ <internal:geospatial> function decimal_to_dms ] {
@@ -89,7 +89,7 @@ Extension [ <persistent> extension #118 geospatial version 0.3.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $geoJsonPointFrom ]
Parameter #1 [ <required> $geoJsonPointTo ]
- Parameter #2 [ <optional> $reference_ellipsoid ]
+ Parameter #2 [ <optional> $reference_ellipsoid = <default> ]
}
}
Function [ <internal:geospatial> function rdp_simplify ] {
diff --git a/php-pecl-geospatial.spec b/php-pecl-geospatial.spec
index 8298f91..64c3b71 100644
--- a/php-pecl-geospatial.spec
+++ b/php-pecl-geospatial.spec
@@ -1,30 +1,27 @@
# remirepo spec file for php-pecl-geospatial
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-geospatial
-%endif
+%{?scl:%scl_package php-pecl-geospatial}
-%global gh_commit c6db5d5b5a4307fcaa29303c703bbe8638484674
+%global gh_commit d3f3ab0a836f10eacb7e117c06f12ea57e1e8649
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-geospatial
%global gh_project geospatial
#global gh_date 20150908
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name geospatial
-%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
%global ini_name 40-%{pecl_name}.ini
-%global with_fastlz 1
+
+%bcond_without tests
Summary: PHP Extension to handle common geospatial functions
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.3.1
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.3.2
%if 0%{?gh_date:1}
Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -51,26 +48,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -169,7 +146,7 @@ fi
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
@@ -188,7 +165,7 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
@@ -236,6 +213,9 @@ fi
%changelog
+* Thu Aug 11 2022 Remi Collet <remi@remirepo.net> - 0.3.2-1
+- update to 0.3.2
+
* Thu Jan 28 2021 Remi Collet <remi@remirepo.net> - 0.3.1-1
- update to 0.3.1
- raise dependency on PHP 7.0