summaryrefslogtreecommitdiffstats
path: root/php-pecl-geospatial.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-28 17:14:39 +0100
committerRemi Collet <remi@remirepo.net>2021-01-28 17:14:39 +0100
commitc88c334e58119956139378f19df82a7e1e64d854 (patch)
treed891f4445ecac1545c33d76231e23569411dac40 /php-pecl-geospatial.spec
parent88bc5f8431eac15c9c3a03730126061cf556bd04 (diff)
update to 0.3.1
raise dependency on PHP 7.0
Diffstat (limited to 'php-pecl-geospatial.spec')
-rw-r--r--php-pecl-geospatial.spec29
1 files changed, 10 insertions, 19 deletions
diff --git a/php-pecl-geospatial.spec b/php-pecl-geospatial.spec
index c9e0513..8298f91 100644
--- a/php-pecl-geospatial.spec
+++ b/php-pecl-geospatial.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-geospatial
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,7 +11,7 @@
%scl_package php-pecl-geospatial
%endif
-%global gh_commit 5e1d4b2083eb078019e599175076370c2873521f
+%global gh_commit c6db5d5b5a4307fcaa29303c703bbe8638484674
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-geospatial
%global gh_project geospatial
@@ -19,30 +19,25 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name geospatial
%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
%global with_fastlz 1
Summary: PHP Extension to handle common geospatial functions
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.1
+Version: 0.3.1
%if 0%{?gh_date:1}
Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-Patch0: %{pecl_name}-php8.patch
-
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -77,12 +72,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
The extension currently has implementations of the Haversine and
@@ -104,8 +93,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .pr
-
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_GEOSPATIAL_VERSION/{s/.* "//;s/".*$//;p}' php_geospatial.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -249,6 +236,10 @@ fi
%changelog
+* Thu Jan 28 2021 Remi Collet <remi@remirepo.net> - 0.3.1-1
+- update to 0.3.1
+- raise dependency on PHP 7.0
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 0.2.1-3
- add patch for PHP 8 from
https://github.com/php-geospatial/geospatial/pull/27