summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-05 08:41:31 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-05 08:41:31 +0100
commit9e7d232a2f46abca7e3e11ef0d67d327e064d3b1 (patch)
tree4518f33b464092aa414761b74cdb47e14fa1e36e
php-pecl-geospatial: 0.1.0 - New extension
-rw-r--r--Makefile4
-rw-r--r--REFLECTION119
-rw-r--r--php-pecl-geospatial.spec252
3 files changed, 375 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..aa647dd
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,119 @@
+Extension [ <persistent> extension #96 geospatial version 0.1.0 ] {
+
+ - Constants [4] {
+ Constant [ double GEO_DEG_TO_RAD ] { 0.017453292519943 }
+ Constant [ double GEO_EARTH_RADIUS ] { 6378137 }
+ Constant [ integer GEO_AIRY_1830 ] { 2 }
+ Constant [ integer GEO_WGS84 ] { 1 }
+ }
+
+ - Functions {
+ Function [ <internal:geospatial> function haversine ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $geoJsonPointFrom ]
+ Parameter #1 [ <required> $geoJsonPointTo ]
+ Parameter #2 [ <optional> $radius ]
+ }
+ }
+ Function [ <internal:geospatial> function initial_bearing ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $geoJsonPointFrom ]
+ Parameter #1 [ <required> $geoJsonPointTo ]
+ Parameter #2 [ <optional> $radius ]
+ }
+ }
+ Function [ <internal:geospatial> function fraction_along_gc_line ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $geoJsonPointFrom ]
+ Parameter #1 [ <required> $geoJsonPointTo ]
+ Parameter #2 [ <required> $fraction ]
+ Parameter #3 [ <optional> $radius ]
+ }
+ }
+ Function [ <internal:geospatial> function helmert ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $x ]
+ Parameter #1 [ <required> $y ]
+ Parameter #2 [ <required> $z ]
+ Parameter #3 [ <optional> $from_reference_ellipsoid ]
+ Parameter #4 [ <optional> $to_reference_ellipsoid ]
+ }
+ }
+ Function [ <internal:geospatial> function polar_to_cartesian ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $latitude ]
+ Parameter #1 [ <required> $longitude ]
+ Parameter #2 [ <required> $reference_ellipsoid ]
+ }
+ }
+ Function [ <internal:geospatial> function cartesian_to_polar ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $x ]
+ Parameter #1 [ <required> $y ]
+ Parameter #2 [ <required> $z ]
+ Parameter #3 [ <required> $reference_ellipsoid ]
+ }
+ }
+ Function [ <internal:geospatial> function transform_datum ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $latitude ]
+ Parameter #1 [ <required> $longitude ]
+ Parameter #2 [ <required> $from_reference_ellipsoid ]
+ Parameter #3 [ <required> $to_reference_ellipsoid ]
+ }
+ }
+ Function [ <internal:geospatial> function dms_to_decimal ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $degrees ]
+ Parameter #1 [ <required> $minutes ]
+ Parameter #2 [ <required> $seconds ]
+ Parameter #3 [ <optional> $direction ]
+ }
+ }
+ Function [ <internal:geospatial> function decimal_to_dms ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $decimal ]
+ Parameter #1 [ <required> $coordinate ]
+ }
+ }
+ Function [ <internal:geospatial> function vincenty ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $geoJsonPointFrom ]
+ Parameter #1 [ <required> $geoJsonPointTo ]
+ Parameter #2 [ <optional> $reference_ellipsoid ]
+ }
+ }
+ Function [ <internal:geospatial> function rdp_simplify ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $pointsArray ]
+ Parameter #1 [ <required> $epsilon ]
+ }
+ }
+ Function [ <internal:geospatial> function interpolate_linestring ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $GeoJSONLineString ]
+ Parameter #1 [ <required> $epsilon ]
+ }
+ }
+ Function [ <internal:geospatial> function interpolate_polygon ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $GeoJSONPolygon ]
+ Parameter #1 [ <required> $epsilon ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-geospatial.spec b/php-pecl-geospatial.spec
new file mode 100644
index 0000000..904b191
--- /dev/null
+++ b/php-pecl-geospatial.spec
@@ -0,0 +1,252 @@
+# remirepo spec file for php-pecl-geospatial
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%endif
+
+%{?scl: %scl_package php-pecl-geospatial}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global gh_commit 27547d489d5b4fc41cce0a0d3118979d6c10c0cf
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php-geospatial
+%global gh_project geospatial
+#global gh_date 20150908
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name geospatial
+%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%global with_fastlz 1
+
+Summary: PHP Extension to handle common geospatial functions
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 0.1.0
+%if 0%{?gh_date:1}
+Release: 0.6.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
+
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 5.4
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+# Package have be renamed
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared object
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+The extension currently has implementations of the Haversine and
+Vincenty's formulas for calculating distances, an initial bearing calculation
+function, a Helmert transformation function to transfer between different
+supported datums, conversions between polar and Cartesian coordinates,
+conversions between Degree/Minute/Seconds and decimal degrees, a method to
+simplify linear geometries, as well as a method to calculate intermediate
+points on a LineString.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package.xml .
+
+cd NTS
+
+# Check version as upstream often forget to update this
+extver=$(sed -n '/#define PHP_GEOSPATIAL_VERSION/{s/.* "//;s/".*$//;p}' php_geospatial.h)
+if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+# Drop in the bit of configuration
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} module
+extension = %{pecl_name}.so
+EOF
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+peclconf() {
+%configure \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd NTS
+
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%else
+: Upstream test suite disabled
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%else
+: Upstream test suite disabled
+%endif
+%endif
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Sat Dec 5 2015 Remi Collet <remi@fedoraproject.org> - 0.1.0-1
+- initial package, version 0.1.0 (experimental) \ No newline at end of file