summaryrefslogtreecommitdiffstats
path: root/php-pecl-geoip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-geoip.spec')
-rw-r--r--php-pecl-geoip.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-pecl-geoip.spec b/php-pecl-geoip.spec
index 8f45a33..41bac36 100644
--- a/php-pecl-geoip.spec
+++ b/php-pecl-geoip.spec
@@ -17,9 +17,6 @@
%endif
%{?scl: %scl_package php-pecl-geoip}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%define pecl_name geoip
%global with_zts 0%{?__ztsphp:1}
@@ -32,7 +29,7 @@
Name: %{?sub_prefix}php-pecl-geoip
Version: 1.1.0
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Extension to map IP addresses to geographic places
Group: Development/Languages
License: PHP
@@ -53,10 +50,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -98,7 +97,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -c -q
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
mv %{pecl_name}-%{version} NTS
@@ -190,6 +191,7 @@ NO_INTERACTION=1 \
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -206,6 +208,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -224,6 +227,9 @@ fi
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-10
+- adapt for F24
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-9
- rebuild for PHP 7.0.0RC5 new API version