summaryrefslogtreecommitdiffstats
path: root/php-pecl-geoip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-geoip.spec')
-rw-r--r--php-pecl-geoip.spec30
1 files changed, 15 insertions, 15 deletions
diff --git a/php-pecl-geoip.spec b/php-pecl-geoip.spec
index 41bac36..fdf776f 100644
--- a/php-pecl-geoip.spec
+++ b/php-pecl-geoip.spec
@@ -14,12 +14,11 @@
%else
%global sub_prefix %{scl_prefix}
%endif
+%scl_package php-pecl-geoip
%endif
-%{?scl: %scl_package php-pecl-geoip}
-
%define pecl_name geoip
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -28,19 +27,14 @@
Name: %{?sub_prefix}php-pecl-geoip
-Version: 1.1.0
-Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Extension to map IP addresses to geographic places
Group: Development/Languages
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# http://svn.php.net/viewvc?view=revision&revision=333464
-Patch0: geoip-build.patch
-# http://svn.php.net/viewvc?view=revision&revision=335948
-Patch1: geoip-php7.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: GeoIP-devel
BuildRequires: %{?scl_prefix}php-devel
@@ -54,8 +48,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -75,6 +71,10 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -104,9 +104,6 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p0 -b .svn
-%patch1 -p3 -b .svn
-
extver=$(sed -n '/#define PHP_GEOIP_VERSION/{s/.* "//;s/".*$//;p}' php_geoip.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream version is ${extver}, expecting %{version}.
@@ -174,8 +171,8 @@ done
%endif
cd NTS
-# TODO America/Toronto instead of America/Montreal
-rm tests/013.phpt
+# Missing IPv6 data
+rm tests/019.phpt
TEST_PHP_EXECUTABLE=%{__php} \
REPORT_EXIT_STATUS=1 \
@@ -227,6 +224,9 @@ fi
%changelog
+* Thu Sep 01 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Update to 1.1.1
+
* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-10
- adapt for F24