summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
commit8b0dbd19573f1ece4034041601eeaf2604a4abea (patch)
treeb093a7d2cfc73e3b7f44362f0942ae67ccf20746
repo reorg
-rw-r--r--Makefile4
-rw-r--r--geoip-tests.patch25
-rw-r--r--php-pecl-geoip.spec159
3 files changed, 188 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/geoip-tests.patch b/geoip-tests.patch
new file mode 100644
index 0000000..335568b
--- /dev/null
+++ b/geoip-tests.patch
@@ -0,0 +1,25 @@
+Index: tests/014.phpt
+===================================================================
+--- tests/014.phpt (revision 311865)
++++ tests/014.phpt (working copy)
+@@ -7,17 +7,15 @@
+ --FILE--
+ <?php
+
+-var_dump(geoip_time_zone_by_country_and_region('CA',''));
+-var_dump(geoip_time_zone_by_country_and_region('CA',NULL));
+-var_dump(geoip_time_zone_by_country_and_region('CA'));
++var_dump(geoip_time_zone_by_country_and_region('CA','AB'));
++var_dump(geoip_time_zone_by_country_and_region('CM',NULL));
+ var_dump(geoip_time_zone_by_country_and_region(NULL,''));
+ var_dump(geoip_time_zone_by_country_and_region(NULL,NULL));
+
+ ?>
+ --EXPECTF--
+ string(%d) "America/%s"
+-string(%d) "America/%s"
+-string(%d) "America/%s"
++string(%d) "Africa/Lagos"
+
+ Warning: geoip_time_zone_by_country_and_region(): You need to specify at least the country code. in %s on line %d
+ bool(false)
diff --git a/php-pecl-geoip.spec b/php-pecl-geoip.spec
new file mode 100644
index 0000000..7351ad5
--- /dev/null
+++ b/php-pecl-geoip.spec
@@ -0,0 +1,159 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%define pecl_name geoip
+
+Name: php-pecl-geoip
+Version: 1.0.8
+Release: 2%{?dist}
+Summary: Extension to map IP addresses to geographic places
+Group: Development/Languages
+License: PHP
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://bugs.php.net/bug.php?id=59804
+Patch1: geoip-tests.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: GeoIP-devel
+BuildRequires: php-devel
+BuildRequires: php-pear >= 1:1.4.0
+
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Provides: php-pecl(%{pecl_name}) = %{version}
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+This PHP extension allows you to find the location of an IP address
+City, State, Country, Longitude, Latitude, and other information as
+all, such as ISP and connection type. It makes use of Maxminds geoip
+database
+
+
+%prep
+%setup -c -q
+
+extver=$(sed -n '/#define PHP_GEOIP_VERSION/{s/.* "//;s/".*$//;p}' %{pecl_name}-%{version}/php_geoip.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+cd %{pecl_name}-%{version}
+%patch1 -p0 -b .tests
+cd ..
+
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+cp -pr %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+make -C %{pecl_name}-%{version} \
+ install INSTALL_ROOT=%{buildroot}
+
+make -C %{pecl_name}-%{version}-zts \
+ install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# install config file
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+
+
+%check
+cd %{pecl_name}-%{version}
+
+TEST_PHP_EXECUTABLE=%{__php} \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+%{__php} run-tests.php \
+ -n -q \
+ -d extension_dir=modules \
+ -d extension=%{pecl_name}.so
+
+
+%clean
+rm -rf %{buildroot}
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_name}-%{version}/{README,ChangeLog}
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+%{php_ztsextdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Sun Nov 13 2011 Remi Collet <remi@fedoraproject.org> - 1.0.8-2
+- build against php 5.4
+
+* Mon Oct 24 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.0.8-1
+- update to 1.0.8
+
+* Sat Oct 15 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.0.7-7
+- upstream patch for https://bugs.php.net/bug.php?id=60066
+
+* Wed Oct 05 2011 Remi Collet <Fedora@FamilleCollet.com> - 1.0.7-6
+- ZTS extension
+- spec cleanups
+- run test suite
+- patch for https://bugs.php.net/bug.php?id=60066
+- patch for https://bugs.php.net/bug.php?id=59804
+
+* Fri Jul 15 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.0.7-6
+- Fix bugzilla #715693
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> 1.0.7-3
+- rebuild for new PHP 5.3.0 ABI (20090626)
+
+* Mon Jun 22 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.0.7-2
+- Fix timestamps on installed files
+
+* Sun Jun 14 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.0.7-1
+- Initial RPM package