summaryrefslogtreecommitdiffstats
path: root/php-pecl-gearman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-gearman.spec')
-rw-r--r--php-pecl-gearman.spec54
1 files changed, 18 insertions, 36 deletions
diff --git a/php-pecl-gearman.spec b/php-pecl-gearman.spec
index 66935d5..0349188 100644
--- a/php-pecl-gearman.spec
+++ b/php-pecl-gearman.spec
@@ -13,12 +13,6 @@
%scl_package php-pecl-gearman
%endif
-%global gh_commit afd2ed880c67455fbf28097dfde7bd3e368c183e
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20200120
-%global gh_owner wcgallego
-%global gh_project pecl-gearman
-%global with_tests 0%{?_with_tests:1}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name gearman
%if "%{php_version}" < "5.6"
@@ -27,22 +21,24 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global extver 2.0.6
+%global extver 2.1.0
%global libver 1.1.0
Name: %{?sub_prefix}php-pecl-gearman
Version: %{extver}
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PHP wrapper to libgearman
License: PHP
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+URL: https://pecl.php.net/package/gearman
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: libgearman-devel > %{libver}
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
# Required by phpize
BuildRequires: autoconf, automake, libtool
@@ -60,32 +56,20 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -100,13 +84,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{gh_project}-%{gh_commit} NTS
-%{__php} -r '
- $pkg = simplexml_load_file("NTS/package.xml");
- $pkg->date = substr("%{gh_date}",0,4)."-".substr("%{gh_date}",4,2)."-".substr("%{gh_date}",6,2);
- $pkg->version->release = "%{version}";
- $pkg->asXML("package.xml");
-'
+mv %{pecl_name}-%{version} NTS
# Dont register tests on install
sed -e 's/role="test"/role="src"/' \
@@ -174,13 +152,13 @@ done
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
@@ -219,6 +197,10 @@ fi
%changelog
+* Sun Jan 17 2021 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+- sources from pecl
+
* Thu Feb 6 2020 Remi Collet <remi@remirepo.net> - 2.0.6-2
- add upstream patch for PHP 7.4
https://github.com/remicollet/remirepo/issues/139