summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION22
-rw-r--r--php-pecl-gearman.spec24
3 files changed, 33 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..bb18323
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+gearman
+
+gearman support => enabled
+extension version => 2.0.4
+libgearman version => 1.1.17
+Default TCP Host => localhost
+Default TCP Port => 4730
diff --git a/REFLECTION b/REFLECTION
index fdf7f35..d5e2c5a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 gearman version 2.0.3 ] {
+Extension [ <persistent> extension #89 gearman version 2.0.4 ] {
- Constants [157] {
Constant [ string GEARMAN_DEFAULT_TCP_HOST ] { localhost }
@@ -255,17 +255,19 @@ Extension [ <persistent> extension #86 gearman version 2.0.3 ] {
}
Function [ <internal:gearman> function gearman_client_add_server ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $client_object ]
Parameter #1 [ <required> $host ]
Parameter #2 [ <required> $port ]
+ Parameter #3 [ <required> $enableExceptionHandler ]
}
}
Function [ <internal:gearman> function gearman_client_add_servers ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $client_object ]
Parameter #1 [ <required> $servers ]
+ Parameter #2 [ <required> $setupExceptionHandler ]
}
}
Function [ <internal:gearman> function gearman_client_wait ] {
@@ -814,7 +816,7 @@ Extension [ <persistent> extension #86 gearman version 2.0.3 ] {
- Properties [0] {
}
- - Methods [44] {
+ - Methods [45] {
Method [ <internal:gearman, ctor> public method __construct ] {
- Parameters [0] {
@@ -900,16 +902,18 @@ Extension [ <persistent> extension #86 gearman version 2.0.3 ] {
Method [ <internal:gearman> public method addServer ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $host ]
Parameter #1 [ <required> $port ]
+ Parameter #2 [ <required> $enableExceptionHandler ]
}
}
Method [ <internal:gearman> public method addServers ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $servers ]
+ Parameter #1 [ <required> $setupExceptionHandler ]
}
}
@@ -1141,6 +1145,12 @@ Extension [ <persistent> extension #86 gearman version 2.0.3 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:gearman> public method enableExceptionHandler ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-gearman.spec b/php-pecl-gearman.spec
index e12dfb7..1ff43cb 100644
--- a/php-pecl-gearman.spec
+++ b/php-pecl-gearman.spec
@@ -13,7 +13,7 @@
%scl_package php-pecl-gearman
%endif
-%global gh_commit 4cb9afcc9dc73a8dd8bcd481f9e8df25a09048fc
+%global gh_commit d948be1a937b1ebbfd5ad5ab84214398ec4ad777
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_date 20161112
%global gh_owner wcgallego
@@ -27,24 +27,22 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global extver 2.0.3
+%global extver 2.0.4
%global libver 1.1.0
Name: %{?sub_prefix}php-pecl-gearman
Version: %{extver}
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PHP wrapper to libgearman
-Group: Development/Tools
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
BuildRequires: libgearman-devel > %{libver}
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
# Required by phpize
BuildRequires: autoconf, automake, libtool
@@ -155,8 +153,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -190,11 +186,7 @@ done
%endif
-%clean
-rm -rf %{buildroot}
-
-
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -215,7 +207,6 @@ fi
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -230,6 +221,9 @@ fi
%changelog
+* Wed Jun 27 2018 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+
* Tue Oct 3 2017 Remi Collet <remi@remirepo.net> - 2.0.3-4
- F27: release bump