summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
commit297fa3a997b74a91776da4c0bf55fad34e936467 (patch)
tree709066474675d55955380c723946282ed87d1474
repo reorg
-rw-r--r--Makefile4
-rw-r--r--php-pecl-gearman-dev.spec174
-rw-r--r--php-pecl-gearman.spec154
3 files changed, 332 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/php-pecl-gearman-dev.spec b/php-pecl-gearman-dev.spec
new file mode 100644
index 0000000..b59bcd2
--- /dev/null
+++ b/php-pecl-gearman-dev.spec
@@ -0,0 +1,174 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global pecl_name gearman
+
+
+Name: php-pecl-gearman
+Version: 1.0.2
+Release: 3%{?dist}
+Summary: PHP wrapper to libgearman
+
+Group: Development/Tools
+License: PHP
+URL: http://gearman.org
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: php-devel, libgearman-devel > 0.21
+BuildRequires: php-pear
+# Required by phpize
+BuildRequires: autoconf, automake, libtool
+# Temporary workaround for https://bugzilla.redhat.com/819209
+BuildRequires: libgearman-1.0
+BuildRequires: libgearman-1.0-devel
+
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+This extension uses libgearman library to provide API for
+communicating with gearmand, and writing clients and workers
+
+
+%prep
+%setup -q -c
+
+extver=$(sed -n '/#define PHP_GEARMAN_VERSION/{s/.* "//;s/".*$//;p}' %{pecl_name}-%{version}/php_gearman.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+cat >%{pecl_name}.ini <<EOF
+; enable %{pecl_name} extension
+extension=%{pecl_name}.so
+EOF
+
+cp -pr %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+make -C %{pecl_name}-%{version} \
+ install INSTALL_ROOT=%{buildroot}
+
+make -C %{pecl_name}-%{version}-zts \
+ install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# install config file
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+
+
+%check
+# simple module load test
+%{__php} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%{__ztsphp} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}-zts/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_name}-%{version}/{ChangeLog,README,CREDITS,EXPERIMENTAL,LICENSE}
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+%{php_ztsextdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Sat May 05 2012 Remi Collet <remi@fedoraproject.org> - 1.0.2-3
+- add BR libgearman-1.0 + libgearman-1.0-devel
+ Workaround for https://bugzilla.redhat.com/819209
+
+* Tue Mar 06 2012 Remi Collet <remi@fedoraproject.org> - 1.0.2-2
+- update to 1.0.2 for PHP 5.4
+
+* Tue Mar 06 2012 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2 for PHP 5.3
+- spec clean up
+
+* Fri Dec 09 2011 Remi Collet <remi@fedoraproject.org> - 1.0.1-2
+- update to 1.0.1, build against php 5.4
+
+* Fri Dec 09 2011 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- update to 1.0.1
+
+* Mon Dec 05 2011 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- build against php 5.4
+
+* Mon Dec 05 2011 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- update to 1.0.0
+- raise dependency to libgearman 0.21 (si f16 only)
+
+* Mon Nov 14 2011 Remi Collet <remi@fedoraproject.org> - 0.8.0-2
+- build against php 5.4
+
+* Sat Oct 15 2011 Remi Collet <Fedora@FamilleCollet.com> - 0.8.0-1
+- update to 0.8.0
+- ZTS extension
+- spec cleanup and minimal %%check
+- fix requires
+
+* Fri Aug 12 2011 Jesse Keating <jkeating@redhat.com> - 0.7.0-5
+- Rebuild for broken deps
+
+* Mon Apr 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-4
+- fix setup and package.xml install
+
+* Mon Apr 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-3
+- correct macros, add license to files
+
+* Fri Apr 08 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-2
+- correct package following pecl packaging guidelines
+
+* Fri Mar 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-1
+- Initial Packaging
+
diff --git a/php-pecl-gearman.spec b/php-pecl-gearman.spec
new file mode 100644
index 0000000..a981198
--- /dev/null
+++ b/php-pecl-gearman.spec
@@ -0,0 +1,154 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global pecl_name gearman
+
+
+Name: php-pecl-gearman
+Version: 0.8.1
+Release: 2%{?dist}
+Summary: PHP wrapper to libgearman
+
+Group: Development/Tools
+License: PHP
+URL: http://gearman.org
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: php-devel, libgearman-devel > 0.10
+BuildRequires: php-pear
+# Required by phpize
+BuildRequires: autoconf, automake, libtool
+
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+This extension uses libgearman library to provide API for
+communicating with gearmand, and writing clients and workers
+
+
+%prep
+%setup -q -c
+
+extver=$(sed -n '/#define PHP_GEARMAN_VERSION/{s/.* "//;s/".*$//;p}' %{pecl_name}-%{version}/php_gearman.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+cat >%{pecl_name}.ini <<EOF
+; enable %{pecl_name} extension
+extension=%{pecl_name}.so
+EOF
+
+cp -pr %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+
+make -C %{pecl_name}-%{version} \
+ install INSTALL_ROOT=%{buildroot}
+
+make -C %{pecl_name}-%{version}-zts \
+ install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# install config file
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+
+
+%check
+
+# simple module load test
+%{__php} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%{__ztsphp} --no-php-ini \
+ --define extension_dir=%{pecl_name}-%{version}-zts/modules \
+ --define extension=%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_name}-%{version}/{ChangeLog,README,CREDITS,EXPERIMENTAL,LICENSE}
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+%{php_ztsextdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Fri Dec 09 2011 Remi Collet <remi@fedoraproject.org> - 0.8.1-2
+- update to 0.8.1, build against php 5.4
+
+* Fri Dec 09 2011 Remi Collet <remi@fedoraproject.org> - 0.8.1-1
+- update to 0.8.1
+
+* Mon Nov 14 2011 Remi Collet <remi@fedoraproject.org> - 0.8.0-2
+- build against php 5.4
+
+* Sat Oct 15 2011 Remi Collet <Fedora@FamilleCollet.com> - 0.8.0-1
+- update to 0.8.0
+- ZTS extension
+- spec cleanup and minimal %%check
+- fix requires
+
+* Fri Aug 12 2011 Jesse Keating <jkeating@redhat.com> - 0.7.0-5
+- Rebuild for broken deps
+
+* Mon Apr 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-4
+- fix setup and package.xml install
+
+* Mon Apr 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-3
+- correct macros, add license to files
+
+* Fri Apr 08 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-2
+- correct package following pecl packaging guidelines
+
+* Fri Mar 11 2011 Paul Whalen <paul.whalen@senecac.on.ca> 0.7.0-1
+- Initial Packaging
+