summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-09 11:14:17 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-09 11:14:17 +0100
commit1be073f8a2d891e771a02d56997a5575e86ba6a6 (patch)
treeee3a0c2a010b2d00733255aa60f58c337160855b
parent18bcc5367e148173a4439ad2e24955e6811ecc6d (diff)
php-pecl-gearman: F24
-rw-r--r--php-pecl-gearman.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-gearman.spec b/php-pecl-gearman.spec
index 062175e..e21caec 100644
--- a/php-pecl-gearman.spec
+++ b/php-pecl-gearman.spec
@@ -17,9 +17,6 @@
%endif
%{?scl: %scl_package php-pecl-gearman}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name gearman
%global with_zts 0%{?__ztsphp:1}
@@ -35,7 +32,7 @@
Name: %{?sub_prefix}php-pecl-gearman
Version: %{extver}
-Release: 7%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 8%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PHP wrapper to libgearman
Group: Development/Tools
@@ -55,10 +52,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -89,14 +88,16 @@ communicating with gearmand, and writing clients and workers
Documentation: http://php.net/gearman
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -q -c
# Dont register tests on install
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
mv %{pecl_name}-%{version} NTS
@@ -172,6 +173,7 @@ done
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -188,6 +190,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -206,6 +209,9 @@ fi
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.1.2-8
+- adapt for F24
+
* Sat Jun 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-7
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets