summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-12 08:46:23 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-12 08:46:23 +0100
commit19054138d63d9c646d51ebd3a4697ad1d341dec2 (patch)
tree632445718ebd933c9a82292423b938406cff5ebc
parent8a5cc3a0fc888e97cfe6bd17708d8d6025e1b9a3 (diff)
php-pecl-gearman: 2.0.2
-rw-r--r--REFLECTION-DEV72
-rw-r--r--php-pecl-gearman-dev.spec11
2 files changed, 44 insertions, 39 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index a129eea..2f0fa32 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #84 gearman version 2.0.1 ] {
+Extension [ <persistent> extension #85 gearman version 2.0.2 ] {
- Constants [157] {
Constant [ string GEARMAN_DEFAULT_TCP_HOST ] { localhost }
@@ -421,6 +421,14 @@ Extension [ <persistent> extension #84 gearman version 2.0.1 ] {
Parameter #4 [ <optional> $unique ]
}
}
+ Function [ <internal:gearman> function gearman_client_add_task_status ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $client_object ]
+ Parameter #1 [ <required> $job_handle ]
+ Parameter #2 [ <optional> $context ]
+ }
+ }
Function [ <internal:gearman> function gearman_client_set_workload_callback ] {
- Parameters [2] {
@@ -840,32 +848,28 @@ Extension [ <persistent> extension #84 gearman version 2.0.1 ] {
Method [ <internal:gearman> public method options ] {
- - Parameters [1] {
- Parameter #0 [ <required> $client_object ]
+ - Parameters [0] {
}
}
Method [ <internal:gearman> public method setOptions ] {
- - Parameters [2] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $option ]
+ - Parameters [1] {
+ Parameter #0 [ <required> $option ]
}
}
Method [ <internal:gearman> public method addOptions ] {
- - Parameters [2] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $option ]
+ - Parameters [1] {
+ Parameter #0 [ <required> $option ]
}
}
Method [ <internal:gearman> public method removeOptions ] {
- - Parameters [2] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $option ]
+ - Parameters [1] {
+ Parameter #0 [ <required> $option ]
}
}
@@ -1025,45 +1029,41 @@ Extension [ <persistent> extension #84 gearman version 2.0.1 ] {
Method [ <internal:gearman> public method addTaskLow ] {
- - Parameters [5] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $function_name ]
- Parameter #2 [ <required> $workload ]
- Parameter #3 [ <optional> $context ]
- Parameter #4 [ <optional> $unique ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <required> $workload ]
+ Parameter #2 [ <optional> $context ]
+ Parameter #3 [ <optional> $unique ]
}
}
Method [ <internal:gearman> public method addTaskBackground ] {
- - Parameters [5] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $function_name ]
- Parameter #2 [ <required> $workload ]
- Parameter #3 [ <optional> $context ]
- Parameter #4 [ <optional> $unique ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <required> $workload ]
+ Parameter #2 [ <optional> $context ]
+ Parameter #3 [ <optional> $unique ]
}
}
Method [ <internal:gearman> public method addTaskHighBackground ] {
- - Parameters [5] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $function_name ]
- Parameter #2 [ <required> $workload ]
- Parameter #3 [ <optional> $context ]
- Parameter #4 [ <optional> $unique ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <required> $workload ]
+ Parameter #2 [ <optional> $context ]
+ Parameter #3 [ <optional> $unique ]
}
}
Method [ <internal:gearman> public method addTaskLowBackground ] {
- - Parameters [5] {
- Parameter #0 [ <required> $client_object ]
- Parameter #1 [ <required> $function_name ]
- Parameter #2 [ <required> $workload ]
- Parameter #3 [ <optional> $context ]
- Parameter #4 [ <optional> $unique ]
+ - Parameters [4] {
+ Parameter #0 [ <required> $function_name ]
+ Parameter #1 [ <required> $workload ]
+ Parameter #2 [ <optional> $context ]
+ Parameter #3 [ <optional> $unique ]
}
}
diff --git a/php-pecl-gearman-dev.spec b/php-pecl-gearman-dev.spec
index 6c0ff38..db9702c 100644
--- a/php-pecl-gearman-dev.spec
+++ b/php-pecl-gearman-dev.spec
@@ -17,9 +17,9 @@
%scl_package php-pecl-gearman
%endif
-%global gh_commit f7ec3cf044f654a3db4c415658941898a6e4d42f
+%global gh_commit bbc426f5609269de13a0edbea0a821c0c0b952f3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20160816
+%global gh_date 20161112
%global gh_owner wcgallego
%global gh_project pecl-gearman
%global with_tests 0%{?_with_tests:1}
@@ -31,7 +31,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global extver 2.0.1
+%global extver 2.0.2
%global libver 1.1.0
@@ -61,8 +61,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -228,6 +230,9 @@ fi
%changelog
+* Sat Nov 12 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+
* Tue Sep 20 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
- update to 2.0.1 for PHP 7
- use sources from https://github.com/wcgallego/pecl-gearman fork