summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-01 18:14:39 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-01 18:14:39 +0200
commitce5b899e35d995ae028d48b1335820401a04d8ac (patch)
tree9e24992966ff1254a91c8152038cb76cd279c661
parentdd136824e8ac83166666f93c8a42cf2feeea2586 (diff)
php-pecl-fann: cleanup for review
-rw-r--r--php-pecl-fann-dev.spec6
-rw-r--r--php-pecl-fann.spec63
2 files changed, 19 insertions, 50 deletions
diff --git a/php-pecl-fann-dev.spec b/php-pecl-fann-dev.spec
index 7f39163..33c0473 100644
--- a/php-pecl-fann-dev.spec
+++ b/php-pecl-fann-dev.spec
@@ -24,7 +24,7 @@ Summary: Wrapper for FANN Library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.7
Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: BSD
+License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -155,7 +155,7 @@ fi
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_tests}
@@ -171,7 +171,7 @@ REPORT_EXIT_STATUS=1 \
cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_tests}
diff --git a/php-pecl-fann.spec b/php-pecl-fann.spec
index 7f39163..d936562 100644
--- a/php-pecl-fann.spec
+++ b/php-pecl-fann.spec
@@ -6,7 +6,6 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-fann}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -21,46 +20,27 @@
%endif
Summary: Wrapper for FANN Library
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Name: php-pecl-%{pecl_name}
Version: 1.0.7
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: BSD
+Release: 1%{?dist}
+License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: fann-devel > 2.1
-BuildRequires: %{?scl_prefix}php-devel > 5.2
-BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: php-devel > 5.2
+BuildRequires: php-pear
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-
-%if "%{?vendor}" == "Remi Collet"
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-%if "%{php_version}" > "5.4"
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
-%endif
-%endif
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
@@ -119,8 +99,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -155,7 +133,7 @@ fi
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_tests}
@@ -171,7 +149,7 @@ REPORT_EXIT_STATUS=1 \
cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
%if %{with_tests}
@@ -185,12 +163,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
@@ -205,12 +178,11 @@ rm -rf %{buildroot}
%changelog
-* Fri Aug 1 2014 Remi Collet <remi@fedoraproject.org> - 1.0.7-3
+* Fri Aug 1 2014 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
+- cleanup for review
- don't install tests
- fix license handling
- add build option --without tests
-
-* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 1.0.7-2
- add numerical prefix to extension configuration file
* Wed Jan 01 2014 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
@@ -219,9 +191,6 @@ rm -rf %{buildroot}
* Wed Jan 01 2014 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
- Update to 1.0.6 (stable)
-* Fri Nov 29 2013 Remi Collet <rcollet@redhat.com> - 1.0.5-1
-- adapt for SCL
-
* Thu Oct 17 2013 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
- Update to 1.0.5
- install doc in pecl doc_dir