summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-17 06:49:18 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-17 06:49:18 +0200
commit323d54bd7e5a28089cae734612fc5d666e04a941 (patch)
treedf22cf3af59c5e7a4708d38a67caa7387492ea40
parent802fe2b5d5bae5e5e9216b11f09124c54d9e8dd8 (diff)
php-pecl-fann install doc in pecl doc_dir, install tests in pecl test_dir
-rw-r--r--php-pecl-fann.spec15
1 files changed, 14 insertions, 1 deletions
diff --git a/php-pecl-fann.spec b/php-pecl-fann.spec
index 6715cbd..fb50fb8 100644
--- a/php-pecl-fann.spec
+++ b/php-pecl-fann.spec
@@ -106,6 +106,16 @@ make -C ZTS \
install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
%endif
+# Test & Documentation
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do
+ install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do
+ install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
%post
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
@@ -153,7 +163,8 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc NTS/{CREDITS,LICENSE,README.md,examples}
+%doc %{pecl_docdir}/%{pecl_name}
+%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{pecl_name}.ini
%{php_extdir}/%{pecl_name}.so
@@ -167,6 +178,8 @@ rm -rf %{buildroot}
%changelog
* Thu Oct 17 2013 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
- Update to 1.0.5
+- install doc in pecl doc_dir
+- install tests in pecl test_dir
* Sat Oct 12 2013 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
- Update to 1.0.4 (stable)